[RFC] Dell hardware-specific repositories -- testers and feedback needed

Berthold Cogel cogel at rrz.uni-koeln.de
Tue Apr 10 10:39:33 CDT 2007


Michael E Brown schrieb:
> On Tue, Apr 10, 2007 at 02:04:28PM +0200, Berthold Cogel wrote:

>> [root at cipsrv root]# up2date -i dellhw-repository
>> http://linux.dell.com/repo/hardware/mirrors.pl?dellname=pe2950&osname=el3.i386
>> using mirror: http://linux.dell.com//repo/hardware/pe2950/el3.i386
> 
> Did you do manual configuration in the past? That is the only way this
> repo would show up.

Yes. This is what I first added to the file. Sorry!

#
# this is a fragment for the /etc/sysconfig/rhn/sources file.
# copy this file into your rhn sources file to activate.
#
# example:
#   cat dellhw-pe2950-el3.rhn-source >> /etc/sysconfig/rhn/sources
#
yum        dell-hardware-pe2950 null  # forces usage of mirror
yum-mirror dell-hardware-pe2950
http://linux.dell.com/repo/hardware/mirrors.pl?dellname=pe2950&osname=el3.$ARCH

> 
>> Fetching Obsoletes list for channel: rhel-i386-as-3...
>>
>> Fetching Obsoletes list for channel: dell-hardware-pe2950...
> 
> Odd.. the dell-software repository isnt showing up here. Can you check
> /etc/sysconfig/rhn/sources and ensure that the dell-software repos are
> in there?
> 

OK! I've removed my changes and retried the bootstrap part.

[root at cipsrv root]# rpm -q dell-repository
dell-repository-18-0.el3

This package should be installed. Now /etc/sysconfig/rhn/sources isn't
modified! I get:

[root at cipsrv root]# up2date -i dellhw-repository

Fetching Obsoletes list for channel: rhel-i386-as-3...

Fetching rpm headers...

Name                                    Version        Rel
----------------------------------------------------------


The following packages you requested were not found:
dellhw-repository

>> [root at cipsrv root]# up2date-nox --show-available
>> --channel=dell-hardware-pe2950 An error has occurred:
>> This system may not be updated until it is associated with a channel.
>> See /var/log/up2date for more information
> 
> This may very well be the source of the error. Have you registered your
> system with RHN?
> --
> Michael


The system is registered with RHN. But we're updating via a local RHN
proxy. Perhaps this causes the problem...

Regards,
Berthold Cogel





More information about the Linux-PowerEdge mailing list