racadm password bug

Diego Brito Veiga - b04917 diego.veiga at freescale.com
Mon Apr 9 09:32:54 CDT 2007


Hi guys,

I found on list a posted message regarding a bug at the racadm to change 
the root passwd with special characters. Seems that the old password has 
a special character that the racadm don't recognize.
I tried to contact the sender but his email isn't valid anymore. Did 
someone already see it? Is there a workaround?

Linux server 2.4.21-32.0.1.ELsmp
Remote Access Controller (RAC)
Version 2.50
Power Edge 2650

PS: I tried to put the \<special character> but it still didn't work.
The command:
# /usr/sbin/racadm -r IP -i config -g cfgUserAdmin -o 
cfgUserAdminPassword -i 1 <new password>
username: root
password: <old password>

Regards,
Diego

------------------------------------------
Reference to the posted message:


  racadm password issue/bug?

*Mark Jorgensen* markj at primustel.ca 
<mailto:linux-poweredge%40dell.com?Subject=racadm%20password%20issue/bug%3F&In-Reply-To=>
/Wed May 4 10:06:07 CDT 2005/

    * Previous message: PE750 aacraid CERC SATA 1.5/6ch driver disk not
      working on FC3 ?
      <http://lists.us.dell.com/pipermail/linux-poweredge/2005-May/020509.html>
    * Next message: HBA card recommendation
      <http://lists.us.dell.com/pipermail/linux-poweredge/2005-May/020512.html>
    * *Messages sorted by:* [ date ]
      <http://lists.us.dell.com/pipermail/linux-poweredge/2005-May/date.html#20510>
      [ thread ]
      <http://lists.us.dell.com/pipermail/linux-poweredge/2005-May/thread.html#20510>
      [ subject ]
      <http://lists.us.dell.com/pipermail/linux-poweredge/2005-May/subject.html#20510>
      [ author ]
      <http://lists.us.dell.com/pipermail/linux-poweredge/2005-May/author.html#20510>


------------------------------------------------------------------------

Hey folks,

We are having an interesting problem with a password change on our Dell
console cards.

We use the following command:
racadm -r $IP -u root -p $OLDPASS config -g cfgUserAdmin -o
cfgUserAdminPassword -i 1 $NEWPASS

$OLDPASS contains an 8 character password with special characters in it
(for example, a!b!c!d!).  We cannot change this to a new password.  We
have tried escaping the "!"'s.  We CAN currently login to the console card
with the $OLDPASS.

We get the following error when trying it by escaping the characters:

authentication failed.

racadm config: Transport: ERROR: objectIdGet. RC=14

Funny thing is, the last password change we did, we obviously managed to
change the password to the one with the special characters.

It seems the racadm is having trouble with special characters with the
$OLDPASS, but will accept them in the $NEWPASS field.

Is this a known bug?
Is there a workaround for this?

Thanks!
Mark
Primus Canada



More information about the Linux-PowerEdge mailing list