[RFC] additional enhancements for RHEL3/4 for Dell system-specific repo

Tony pthagonal at gmail.com
Fri Apr 6 06:28:58 CDT 2007


On 4/6/07, Michael E Brown <Michael_E_Brown at dell.com> wrote:

> So, please, try it out and let me know. I see from the logs that some
> people have tried it out so far, and really look forward to hearing from
> everybody who has tried it.

Just had a quick play on a CentOS 4.4 test box - which is a PE 430SC.

Using the copy-and paste method for rhn/up2date works fine - grabbed
http://linux.dell.com/repo/hardware/pe0430/dellhw-pe0430-el4.rhn-source
and put it on the end of /etc/sysconfig/rhn/sources and now up2date -l
tells me that there's a newer xgi_Xorg rpm available than the one I've
got installed. Cool!

Not so successful with the yum method, but I'm not so familiar with
yum so it is probably me doing something daft.

I got the EPEL rpms just directly- didn't bother enabling that repo
(maybe my mistake, but I doubt that?) -

rpm -Uvh http://download.fedora.redhat.com/pub/epel/4/i386/firmware-addon-dell-1.2.6-1.el4.noarch.rpm
http://download.fedora.redhat.com/pub/epel/4/i386/firmware-tools-1.2.3-1.el4.noarch.rpm
http://download.fedora.redhat.com/pub/epel/4/i386/libsmbios-bin-0.13.5-1.el4.i386.rpm
http://download.fedora.redhat.com/pub/epel/4/i386/libsmbios-libs-0.13.5-1.el4.i386.rpm

then I got the dell autosys repo for el4:

cd /etc/yum.repos.d/
wget http://linux.dell.com/repo/hardware/dellhw-autosys-el4.repo

Then I edited /etc/yum.conf and add plugins=1 to switch them on.

Now if I try yum check-update I get this error:

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 80, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 196, in getOptionsConfig
    self.doPluginSetup(self.optparser)
  File "__init__.py", line 157, in doPluginSetup
  File "plugins.py", line 134, in __init__
  File "plugins.py", line 176, in _importplugins
  File "plugins.py", line 191, in _loadplugin
  File "/usr/lib/yum-plugins/dellsysidplugin.py", line 11, in ?
    from yum.yumRepo import YumRepository
ImportError: No module named yumRepo

Anyone any ideas what I've done wrong?

Even with my mistake, it seems like an excellent system!!

-- 
Cheers,

Tony



More information about the Linux-PowerEdge mailing list