PowerVault MD 1000 Raid -- Linux Partitioning Problems

Gordon Henderson gordon at drogon.net
Wed Oct 25 11:36:16 CDT 2006


On Wed, 25 Oct 2006, lists at aresgate.net wrote:

> Hi, I am using Debian as well parted is a program recommended to
> partition large volumes and u can get with apt-get isntall parted.

Ah, OK. I've never actually tried to partition a large volume - I
partition the underlying disks and make RAID devices out of them... And
some investigation shows a limit of 2TB for c/f/s disk ...

I just tried parted on a 6TB md device (an MD1000 with 15 x 500GB drives)

bertha:/# parted /dev/md9
GNU Parted 1.6.21 with HFS shrink patch 16

Using /dev/md9
(parted) print
Disk geometry for /dev/md9: 0.000-6193352.750 megabytes
Disk label type: loop
Minor    Start       End     Filesystem  Flags
1          0.000 6193352.750  ext3

so I guess thats ok?

Good luck!

Gordon

>
> ~Vladi
>
> On Wed, 25 Oct 2006 09:04:58 +0100 (BST), Gordon Henderson <gordon at drogon.net> wrote:
> > On Tue, 24 Oct 2006, lists at aresgate.net wrote:
> >
> >> Hi, i have a Dell PowerVault MD 1000 raid and i would like to use it as
> >> one big FS. I am having problems partitioning it with parted. I changed
> >> the label to gpt with mklabel gpt and it can detect the size but
> >> whenever i try to create a partition it does not give an error but
> >> doesnt create anything. Can someone please help?
> >
> > I don't know much about parted & mklabel I'm guessing those are the RH
> > utilities (I'm strictly Debin here), but have you tried a different disk
> > partitioner, eg. cfdisk, fdisk, sfdisk (in that order, although if you
> > have to resort to sfdisk then you're probably doomed ;-)
> >
> > Gordon
>



More information about the Linux-PowerEdge mailing list