IMPI on Debian ( 2650)

Matt_Domsch at Dell.com Matt_Domsch at Dell.com
Tue May 30 07:22:27 CDT 2006


My mistake.  KCS is included in ipmi_si now.

--
Matt Domsch
Software Architect
Dell Linux Solutions linux.dell.com & www.dell.com/linux
Linux on Dell mailing lists @ http://lists.us.dell.com

-----Original Message-----
From: Johann Spies [mailto:jspies at sun.ac.za] 
Sent: Tuesday, May 30, 2006 4:16 AM
To: Domsch, Matt; linux-poweredge-Lists
Subject: Re: IMPI on Debian ( 2650)

On Mon, May 29, 2006 at 03:44:42PM -0500, Matt Domsch wrote:
> > >From what I understand ipmi_kcs_drv is only necessary for the 2.4
> > kernels and I have 2.6.8-3-686-smp
> 
> You'll want a more recent kernel than this.  We've been fixing up the 
> ipmi driver in 2.6.14 and higher (see http://linux.dell.com/ipmi.shtml

> for the kinds of things fixed in each release).
> 
> And, in 2.6, it's no longer called ipmi_kcs_drv, but just ipmi_kcs.
> 
> kernel. Or, just upgrade to 2.6.x latest and it'll "just work". :-)

Thanks Matt. I have compiled 2.6.16 (Debian sources) now and it indeeds
seems to work.  I cannot see an ipmi_kcs-module, however:

% lsmod | grep ipmi
ipmi_si                37924  1
ipmi_devintf            9864  0
ipmi_watchdog          19776  0
ipmi_msghandler        34112  3 ipmi_si,ipmi_devintf,ipmi_watchdog

There is 'ipmi_poweroff' which I did not load at this stage.

Regards
Johann.
-- 
Johann Spies          Telefoon: 021-808 4036
Informasietegnologie, Universiteit van Stellenbosch

     "Do all things without murmurings and disputings; 
      that ye may be blameless and harmless, the sons of 
      God, without rebuke, in the midst of a crooked and 
      perverse nation, among whom ye shine as lights in the 
      world."    Philippians 2:14,15 



More information about the Linux-PowerEdge mailing list