OMSA yum repository on FC5

Matt Domsch Matt_Domsch at dell.com
Tue May 9 21:43:14 CDT 2006


On Wed, May 10, 2006 at 12:30:43AM +0100, Robin Bowes wrote:
> Hi,
> 
> I'm trying to get the OMSA software installed on a PowerEdge 1850
> running FC5.

OMSA 4.5 isn't expected to work on FC5...


> First, a general comment: why bother with the bootstrap script? Why not
> just provide dell.repo files for all supported platforms?

Just to make it "simple" we think.

 
> Anyway, here's how I got on:
> 
> 1. The location of the Vendor GPG keys is wrong for FC5 (and probably
> for other Fedroa versions. It should be:
> 
> 	rpm --import /usr/share/doc/fedora-release-N/RPM-GPG-KEY
> 
> the /doc/ is missing on the web page.

Fixed, thanks.
 
> 2. Running bootstrap.sh: there is no dell-repository-9-0.fc5.noarch.rpm

oops.  will fix asap.
 
> 3. Manually download dell-repository-9-0.fc4.noarch.rpm and install
> 4. Edit dell.repo and replace "4" with "5".


 
> 5. Try: yum install srvadmin-all
> No Match for argument: srvadmin-all
> Nothing to do
> 
> I'm not sure where to go from here.

srvadmin-* packages aren't available in the FC* directories, because
FC* aren't OMSA-supported OSs.  The srvadmin-* packages are in the
RHEL[34] directories because those are OMSA-supported OSs.

There's not a lot of experience reported on this list of people making
OMSA work on FC.  What we posted in the repos for RHEL[34] are the
official OMSA RPMs (without modification).  If there's evidence we can
do likewise for FCx, I'd be open to it.  But I think it's unlikely to
work on FCx given the current kernel dependencies.  This may get
better when OMSA 5.0 is released of course.

Thanks,
Matt

-- 
Matt Domsch
Software Architect
Dell Linux Solutions linux.dell.com & www.dell.com/linux
Linux on Dell mailing lists @ http://lists.us.dell.com



More information about the Linux-PowerEdge mailing list