Openmanage 4.4 on PE2850

Matt Domsch Matt_Domsch at dell.com
Fri Jul 8 07:54:50 CDT 2005


On Fri, Jul 08, 2005 at 01:22:38PM +0200, Guido wrote:
> Hi,
> 
> in the list on
> http://lists.us.dell.com/pipermail/linux-poweredge/2005-May/020765.html
> you wrote:
>  > Version 4.4 should be compatible with this architecture.
> ...regarding OpenManage on the x86_64 architecture.
> 
> I just tried this with the
>    OM-SrvAdmin-Dell-Web-LX-440-_A00.tar.gz
> package on my RHEL4/PE2850 system and started
>    sh srvadmin-install.sh -x
> 
> But I get these error message:
>  > Installing the selected packages.
>  >
>  > warning: instsvc-drivers-5.0.0-1.i386.rpm: V3 DSA signature: NOKEY, 
> key ID 23b66a9d
>  > error: Failed dependencies:
>  >         libncurses.so.5 is needed by srvadmin-isvc-4.4.0-339.i386
>  >         libstdc++-libc6.2-2.so.3 is needed by 
> srvadmin-omacore-4.4.0-339.i386
>  >         libz.so.1 is needed by srvadmin-omacore-4.4.0-339.i386
>  >         libncurses.so.5 is needed by srvadmin-omacore-4.4.0-339.i386
>  >         libpam.so.0 is needed by srvadmin-omacore-4.4.0-339.i386
> 
> All these libraries exist on the system (RHEL4). The '.i386.rpm' 
> extension of the package confuses me.

The userspace components of OMSA 4.4 are still i386 packages, there's
no need for them to be rebuilt as 64-bit applications.  So, you need
to install the i386 versions of the above packages to satisfy the
dependencies.

up2date -i libncurses.i386 compat-libstdc++.i386 libz.i386 \
  libncurses.i386 libpam.i386

or something very similar to that.

Thanks,
Matt

-- 
Matt Domsch
Software Architect
Dell Linux Solutions linux.dell.com & www.dell.com/linux
Linux on Dell mailing lists @ http://lists.us.dell.com



More information about the Linux-PowerEdge mailing list