PowerEdge 400SC printing in Linux

David Duffey dduffey at redhat.com
Sun Oct 24 13:54:01 CDT 2004


Has anyone had success printing via the parallel port of a 400SC in
Linux?

I'm running the the latest bios (A08), RHEL 3 (2.4.21-20), and RHEL 4
beta 1.  The printer is a HP DeskJet 500 that works on two other non-
Dell boxes, one running RHEL 3 and another running Debian (2.4.24
kernel).

Printing "works," but it is extremely slow, and becomes slower over
time.  The first few lines of printing are "normal" but each additional
line becomes slower.  It takes about 30 seconds to print the first two
lines, about 5 minutes to print the first 1/8th of a page, and about 30
minutes to print the first 1/4th of a page, etc.

After about two / three lines of text the printer will "park" the head
because data is arriving so slowly (or not at all).  About 30 seconds
later, it will print another line, park the head, sleep longer, etc.

I've tried all of the LPT settings in the bios (AT, PS2, EPP, ECP) and
various io ranges (378 and 278).  I've used various print drivers
(dj500, hpij, pcl3, etc) available in redhat/system-config-printer, and
even printing directly with "cat filename > /dev/lp0" with the same
results.  I've also tried settings with "tunelp"

The lp probe info returned from the lp module (and tunelp) matches on
the working non-dell box and the non-working 400 sc are the same.  The
data being sent is exactly the same too.

My hunch is that it's a bad 400SC, but haven't done enough testing to
know for sure.

Anyone else experience the same things?  I'm willing to try another OS
(not windows) (fedora, debian, etc) on this Dell machine if others have
had it working, but I suspect that since I tried two major RHEL versions
and different kernels that this will not be the case.  (and RHEL is
working with this printer on another non-Dell).

David

-- 
David Duffey, RHCE
Business Development Manager
Dell | Red Hat




More information about the Linux-PowerEdge mailing list