No gigabit with either bcm5700 or tg3

Sean Dilda agrajag at dragaera.net
Fri Oct 15 08:39:00 CDT 2004


On Fri, 2004-10-15 at 00:36, Chris Brougham wrote:
> Hi Folks,
> 
> I have been tackling this for a few days now. We have a 1750 running 
> Redhat 9 2.4.20-8SMP and neither the tg3 driver nor the download bcm5700 
> driver from Broadcom or the bcm5700 driver on the Dell driver CD will 
> give me a gig connection. The tg3 driver will not even work in the Layer 
> 2 Alcatel 6300 switch. The bcm5700 driver does work in the switch, but 
> only negotiates 100 mb/s. I've tried to upgrade the kernel to 2.4.27 to 
> see if a later tg3 driver works better and that indeed does allow tg3 to 
> connect to the Alcatel switch, but the tg3 driver still won't negotiate 
> gig speeds.
> 

I have a good number of 1750's.  They all connect to Dell PowerConnect
5224 switches at 1000Mb/s full-duplex.  I use the tg3 driver.  I've run
RHL9 on them (with latest updates) and am now running CentOS 3.3 on
them.

I've only had one machine that wouldn't negotiate at gigabit speeds.  I
swapped out the cable, and it worked.  What kind of ethernet cable are
you using?  You should be using at least cat5e.




More information about the Linux-PowerEdge mailing list