Dell PE 1650 and aacraid errors

pzero pzero at hotpop.com
Fri Apr 23 08:23:00 CDT 2004


Hi,
I've a Dell PowerEdge 1650 running Red Hat Enterprise Linux 3 ES (Update 
  1 and all current updates).

I've noticed a few accraid errors in the log file:

---
# cat /var/log/messages | grep aacraid
Apr 22 01:10:48 myserver kernel: Red Hat/Adaptec aacraid driver (1.1.2 
Feb  9 2004 22:51:15)
Apr 22 01:13:31 myserver kernel: aacraid:ID(0:02:0); Error Event 
[command:0x28]
Apr 22 01:13:31 myserver kernel: aacraid:ID(0:02:0); Hardware Error 
[k:0x4,c:0x2,q:0x80]
Apr 22 01:13:31 myserver kernel: aacraid:ID(0:02:0); No Seek Complete
Apr 22 01:13:51 myserver kernel: aacraid:ID(0:02:0) - IO failed, Cmd[0x28]
Apr 22 01:13:51 myserver kernel: aacraid:Drive 0:2:0 returning error
Apr 22 01:13:53 myserver kernel: aacraid:RAID5 Container 0 Drive 0:2:0 
Failure
Apr 22 01:13:53 myserver kernel: aacraid:RAID5 Failover Container 0 No 
Failover Assigned
Apr 22 01:15:06 myserver kernel: aacraid:ID(0:02:0) - Drive spindown failed
Apr 22 01:15:06 myserver kernel: aacraid:Drive 0:2:0 offline on container 0:
Apr 22 01:15:49 myserver kernel: aacraid:Container 0 started REBUILD 
task on drive 0:2:0
Apr 22 02:10:38 myserver kernel: aacraid:Battery charge is now OK
Apr 22 03:26:58 myserver kernel: aacraid:Container 0 completed REBUILD task:
---

Here is some info about the server and the SCSI config (dmesg):

---
SCSI subsystem driver Revision: 1.00
Red Hat/Adaptec aacraid driver (1.1.2 Feb  9 2004 22:51:15)
PCI: Assigned IRQ 3 for device 01:08.1
PCI: Sharing IRQ 3 with 02:06.0
PCI: Found IRQ 3 for device 01:08.1
PCI: Sharing IRQ 3 with 02:06.0
AAC0: kernel 2.7.4 build 3153
AAC0: monitor 2.7.4 build 3153
AAC0: bios 2.7.0 build 3153
AAC0: serial 733421d3fafaf001
PCI: Found IRQ 3 for device 01:08.1
PCI: Sharing IRQ 3 with 02:06.0
scsi0 : percraid
Starting timer : 0 0
blk: queue c5f29c14, I/O limit 4095Mb (mask 0xffffffff)
   Vendor: DELL      Model: PERCRAID RAID5    Rev: V1.0
   Type:   Direct-Access                      ANSI SCSI revision: 02
Starting timer : 0 0
blk: queue c5f29e14, I/O limit 4095Mb (mask 0xffffffff)
Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
SCSI device sda: 71089152 512-byte hdwr sectors (36398 MB)
sda: Write Protect is off
Partition check:
  sda: sda1 sda2 sda3
Journalled Block Device driver loaded
spurious 8259A interrupt: IRQ7.
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
---

I don't know what the aacraid errors mean. Any idea?

Should I worry about them?
How can I avoid them?

Thanks!




More information about the Linux-PowerEdge mailing list