OpenManage 3.7 on Redhat 7.3 latest kernel

Trevor Marshall tmarshall at
Tue Apr 20 09:28:00 CDT 2004

Yes I have the source, symlink etc. I've tried the usual caveats to no avail; I wasn't even sure some of them applied to these later versions of 2.4.20. I received an email off of another list telling me to use OM version 3.3, which actually worked on one of the servers (but not it's twin) ; why would 3.3 install cleanly and not the up to date software? I guess bitching about it's not going to help; I'll go play with the kernel source some more (-;

-----Original Message-----
From: Peter Smith [mailto:peter.smith at]
Sent: Monday, April 19, 2004 8:53 PM
To: linux-poweredge at
Subject: Re: OpenManage 3.7 on Redhat 7.3 latest kernel

I'll mention the obvious.  Do you have the correct kernel source 
installed for that version of kernel?  Is there a symlink for 
/usr/src/linux-2.4?  Also, did you make the ".config" for your current 
kernel in the dir, and did you do anything like "make dep"?  Sometimes 
getting all these things in place is the key to having 3rd-party modules 
build correctly.  Since you have installed Openmanage on your other 
servers, I really doubt you missed any of the above, but I thought I'd ask.


Trevor Marshall wrote:

>Arggh I can't get it to install.. I've put Openmanage on all my other Redhat servers but have three remaining RH7.3 boxes that won't take it.
>The kernel is patched to latest 2.4.20-28.7 but getting errors because it can't load esm.o module. Some people have had this problem with earlier kernels but I have yet to find a fix for this one. 
>I've found some older postings with workarounds for earlier kernels but they didn't work here. I don't want to reboot to an earlier kernel these are production machines.
>/lib/modules/2.4.20-28.7/misc/esm.o: unresolved symbol irq_stat_Rab429fdf
>/lib/modules/2.4.20-28.7/misc/esm.o: unresolved symbol register_chrdev_Rbfa5a630
>Hint: You are trying to load a module without a GPL compatible license
>      and it has unresolved symbols.  Contact the module supplier for
>      assistance, only they can help you.
>This is a RH Errata kernel, the installer shouldn't fail, no? It's telling me my kernel is not supported and I simply cannot accept that.
>Any help greatly appreciated this has been an annoying experience and has taken up far too much of my time already. (-;
>Trevor Marshall
>Systems Administrator
>Tira Wireless
>ph: 416.932.6294 x225
>mob: 416.569.7331
>Linux-PowerEdge mailing list
>Linux-PowerEdge at
>Please read the FAQ at or search the list archives at

More information about the Linux-PowerEdge mailing list