DevLabel / JFS FileSystem... Gary_Lerhaupt at
Mon Apr 12 10:26:01 CDT 2004

Well, certainly something is messed up.  However, the bulk of the code
taken to create partition_uuid was taken verbatim from mount.  This
should include jfs uuid support.  In fact, can you attempt to use mount
to mount by UUID and see if that is successful?


> -----Original Message-----
> From: linux-poweredge-admin at
> [mailto:linux-poweredge-admin at]On Behalf Of Brad Viviano
> Sent: Monday, April 12, 2004 9:13 AM
> To: linux-poweredge at
> Subject: DevLabel / JFS FileSystem...
> This might be alittle off topic, but since devlabel is hosted 
> by Dell, I
> thought someone monitoring this list might know the answer to 
> my question.  I
> have a PE2650 running RHEL 3 Update 1.  I am trying to use 
> DevLabel with a JFS
> based file system which is located on a RAID5 drive set inside my 2650
> connected to the Perc3/DI controller.  When I run devlabel on 
> one of the
> partitions it tells me:
> Uniqueness check failed.  The following devices have the same UUID:
> /dev/sde7
> /dev/sde8
> /dev/sde9
> Failure.
> The device UUID for /dev/sde7 is identical to other devices 
> on your system.
> Because of this, you cannot use devlabel with this device.
> sde7, sde8, and sde9 are all JFS file systems.  I have traced 
> the problem to
> /usr/bin/partition_uuid.  When I run that on any of the 
> filesystems that are
> JFS based it always returns 
> "00000000-0000-0000-0000-000000000000".  But
> partition_uuid works fine for EXT3/SWAP type file systems.  I 
> have loaded the
> latest RPM from with no affect.  
> blkid /dev/sde7
> returns the correct information:
> /dev/sde7: LABEL="raid2c" 
> UUID="e73ea11d-3019-4510-9f67-2160be89279a" TYPE="jfs"
> So I know it is getting a LABEL/UUID.  Is there some patch to 
> devlabel, or do
> I need to do something else (Some tune paramiter) on JFS file 
> systems to get
> devlabel to read the UUID on a JFS filesytem.
> In case anyone is wondering why I don't just use "LABEL=" in 
> /etc/fstab, I was
> using that, but as it turns out my PE2650 crashed last night 
> and left the JFS
> file systems in an unclean state, at reboot I was getting 
> errors saying it was
> unable to locate drive with LABEL=raid2c, but my EXT3 
> FileSystems using
> devlabel mounted without issue.  Turns out the system can not 
> read the LABEL=
> value off a dirty JFS file system, once I manually ran 
> jfs_fsck /dev/sde7 I
> was able to mount without issue.  So I would like to switch 
> to devlabel for
> my JFS file systems.  Any ideas?
> 	Thanks,
> 		-Brad
> -- 
> +-------------------------------------------------------------
> -------------+
> | viviano at          Systems Support          
> Raindrop Geomagic |
> +-------------------------------------------------------------
> -------------+
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at
> Please read the FAQ at or search 
> the list archives at

More information about the Linux-PowerEdge mailing list