NFS problems

Brian linux-poweredge-dell at tracking.zerobelow.org
Thu Apr 8 16:29:01 CDT 2004


Hi,

I've had some NFS problems that started troubling me last week, between 
just two machines. A solaris 8 box has been in production for at least 4 
years now, and a PE2650 (RH9) has been in production for a little over a 
year now. We are porting everything off the Solaris 8 box onto the RH9 
box, but this is taking time, and in the meantime, we need to NFS mount 
the Solaris box from the RH9 box.

When doing any IO from the RH9 box over the NFS link, we periodically get 
Input/output errors, this happens in a wide variety of programs, and seems 
to affect both file IO, and directory lookups. (It can cause the errors 
during a 'find .' as well as a 'dd if=/dev/zero of=oof bs=1024k 
count=100'. This system doesn't have such problems when writing to other 
NFS mounts, and other RH9 boxes don't have problems writing to the Solaris 
box, and this system only had problems starting last Friday. Granted, no 
other pair of systems here has the amount of other load that the 
problematic RH9 and Solaris boxes have, so tests between other systems may 
not be valid.

I've tried a wide variety of the mount options, including soft, hard, 
sync, async, (r/w)size=(4096/8192/32768), nfsvers=(2/3), intr, various 
values for retrans and timeo, tcp, udp. None of these seem to have an 
effect. 

My impression is that with a hard NFS mount, the app shouldn't see 
Input/output errors until the timeout is exceeded, but sometimes the error 
happens instantly, like within the first second...anyone have any ideas 
here? I've tried everything I can think of...

-brian




More information about the Linux-PowerEdge mailing list