PE1750, perc 4/Di, and Redhat 7.2

Wehner, Robert Robert.Wehner at experianems.com
Wed Oct 29 18:31:00 CST 2003


Has anyone gotten this combination to work?

We just got a 1750 in and I've been asked to kickstart it with our standard
RH7.2 install. This install is a stock, out-of-the-box 2.4.7-10smp kernel (I
know, old and unpatched, but we've all got reasons for odd "standards").

I managed to get the NFS kickstart going fine after re-compiling the BOOT
kernel with the 1.18k version of megaraid from LSI's ftp site and making a
new boot floppy using the procedure outlined at
http://www.puschitz.com/Kickstart.shtml.

The problem is that after the install when the server is coming back up, I
get a kernel panic shortly after the bootloader tries to pass off to the
kernel. It basically says "No init found. Try passing 'init=' to the
kernel." Best I can figure is that the megaraid driver is not loading
correctly for some reason and so the disk just isn't there to load anything
from.

Taking a queue from the LSI/Dell provided megaraid RPM on the Dell Server
Assistant CD, I tried to compile a new megaraid.o for the 2.4.7-10smp kernel
using the kernel-source RPM from the 7.2 CD and the appropriate .config from
the kernel-2.4.7-10.src.rpm. This apparently doesn't produce an exact
2.4.7-10smp kernel (slightly different sizes), but I tried to install the
new megaraid.o from this compile anyway using the same scripts from the
megaraid RPM (essentially, installed the megaraid.o in the
/lib/modules/2.4.7-10smp/drivers/scsi/, ran a mkinitrd, and make sure
megaraid is listed in /etc/modules.conf). It didn't work.

I tried again, this time using the whole newly compiled custom
"2.4.7-10smpish" kernel and associated files. Again, it didn't work.

I've tried (increasingly random) variations on this, including adding the
megaraid entries from the RH9 pcitable to /usr/share/kudzu/pcitable on the
1750 during the kickstart. Fooling with /etc/sysconfig/hwconf, etc. But all
this is starting to seem off the mark.

I've pretty much run out of ideas and feel like either this combination of
hardware and OS is just unworkable or I'm missing something totally obvious.
Anyone out there dealt with this before or have any suggestions?

Thanks!

--
Robert Wehner
robert.wehner experianems.com
                    ^@





More information about the Linux-PowerEdge mailing list