e1000 card won't work in a PE2500, will in a 2600.

Mark_Relihan@Dell.com Mark_Relihan at Dell.com
Wed Oct 22 22:59:00 CDT 2003


As these are the card specs, 32-bit or 64-bit, operating at 33 or 66 MHz and
will work in 3.3v or 5v, can you try it in a different slot on the PE2500?
Any one of the white ones will be fine. 

The Green PCI slots are the 66/64 3.3v and is on a different bus than the
other PCI slots. (there are 3 different PCI busses on the PE2500)

Another thing to try would be to put a different 66/64 card in the PE2500
and see if it works.

Mark

-----Original Message-----
From: jason andrade [mailto:jason at rtfmconsult.com] 
Sent: Wednesday, October 22, 2003 9:12 PM
To: ard at waikato.ac.nz
Cc: linux-poweredge at dell.com
Subject: Re: e1000 card won't work in a PE2500, will in a 2600.

On Thu, 23 Oct 2003 ard at waikato.ac.nz wrote:

> [huge elide] but does work in a 2600.

sorry, i can't parse 'elide'.

> Sorry, I really should have put all that in my first post.  It is
> 64-bit card.  From the kernel's PCI database:
>
> Both machines are running 2.4.22-ac4, which has e1000 v5.1.13-k1
> according to e1000_main.c.

the latest intel driver is 5.2.16, e.g

http://planetmirror.com/pub/intel/drivers/linux/current/

have you tried that ?  but see below first..

> Yes.  In the 2500, where the problem exists, I have two patch leads:
> one to a 100Mb/s switch port and the other to a gigabit port on a
> different.  If I plug either of these into the onboard e100, the link
> LED lights up and the switches refresh their arp tables within a few
> seconds.  The gigabit switch negotiates down to 100Mb of course.  If I
> plug either of these two patches into the removable e1000 card,
> everything stays dark.
>
> The strangest part of all this is that the card worked in the 2500 for
> a couple of days.  I think this will have to wait until the 2500 is
> under less load and I can upgrade its system BIOS and run some more
> tests.

unless the card has physically died (can you verify that it hasn't by
putting it into a separate server and seeing it is negotiates and is
usable by the OS?) it is extremely strange that it would stop working
after 2 days.  that would imply it isn't a driver issue but some other
problem.  i'd be working methodically to rule out everything else
at this point, one by one, e.g switch, cable, server, slot before
looking to OS if you knew it worked once.

regards,

-jason

_______________________________________________
Linux-PowerEdge mailing list
Linux-PowerEdge at dell.com
http://lists.us.dell.com/mailman/listinfo/linux-poweredge
Please read the FAQ at http://lists.us.dell.com/faq or search the list
archives at http://lists.us.dell.com/htdig/




More information about the Linux-PowerEdge mailing list