Broadcom driver for PE1750 and RH7.3 (was: Broadcom driver for PE1750 and RHEL ES 2.1)

Marc Prewitt mprewitt at wssource.com
Mon Oct 20 17:20:01 CDT 2003


I'm having problems getting the bcm5700 driver to work on a PE1750 with 
RedHat 7.3.  I can succcessfully build the driver as suggested below but 
when I run an insmod on the generated driver I get this:

$ insmod bcm5700.o
bcm5700.o: unresolved symbol __ioremap_R9eac042a
bcm5700.o: unresolved symbol pci_read_config_word_R46710516
bcm5700.o: unresolved symbol proc_mkdir_R8aabe609
bcm5700.o: unresolved symbol pci_release_regions_Ree185a37
... (many more unresolved symbols)

I have tried this with the 6.x driver below and with the 7.0.0 driver from 
the broadcom site.  Any idea what might be causing this?

Thanks,
Marc Prewitt

----- Original Message -----

Get the latest version of bcm5700 and build for your
present kernel.  Has a source rpm in tarball and do
rpm --rebuild bcm5700....src.rpm
Will build and place binary rpm for running kernel
in /usr/src/redhat/RPMS/i386.  Install with rpm -Uvh --force
and either reboot or ifdown ethX interfaces, rmmod bcm5700,
and then modprobe bcm5700 and should end problems.
If you are running 100 full and not gbit probably need
to add options line below the 2 alias entries for nics
in modules.conf.
options bcm5700 line_speed=100,100 auto_speed=0,0 full_duplex=1,1
http://ftp.us.dell.com/network/bcom_lan_67_rh_src_A00.tar.gz
Requirements are kernel source and rpmbuild packages be
installed as well as standard kernel development things
gcc, make, and so forth.
Steve




More information about the Linux-PowerEdge mailing list