PERC4+Rh7.3+PE1750 megaraid (http://domsch.com/linux/#megaraid) RH7.3 question

Naveen Nathan naveen at dtiserv2.com
Sun Oct 12 01:21:01 CDT 2003


(I hope i didnt send this twice. I sent one already before I signed up with the mailing list.)

Hello,

I'm trying to install RH 7.3 on a new Dell Poweredge 1750. 2 of the hdds
have been setup as raid-1 and have been initialized.

The default RH 7.3 kernel doesnt support the PERC4 Di/S RAID controller, as
stated from http://www.domsch.com/linux/#megaraid . It says 1.18f is needed,
however I think RH 7.3 uses 1.18a. So I went ahead and installed RH 7.3 on a
different server (it is 2.4.22, however it had the old 2.4.18-3 source tree
and I just did make dep && make modules on that tree), and overwrote the
megaraid.c file, and recreated the modules, then copied the .o to a floppy.
During RH 7.3 bootup, I went to a shell, mounted the disk, and tried to
modprobe it, however it failed due to lots of (unresolved) errors. I believe I compiled
to the wrong kernel source tree or something.

Instead, is it possible to do an on the fly compile of the megaraid.c
module. I was using megaraid 1.18k.

I've been spending hours figuring this out, and there is no driver disk
available for the megaraid module for rh 7.3.

Any guidance will be much appreciated. Even a proper working precompiled megaraid.o (for rh7.3 2.4.18-3BOOT kernel) that works on PE1750 would be VERY spiffy :P.

Also it says on the website http://www.domsch.com/linux/#megaraid :

Red Hat Linux 7.3 (kernel 2.4.18-3) includes megaraid v1.18a, and works with all LSI/AMI MegaRAID controllers. It doesnt work with the megaraid controller used in the PE1750 server.

This above statement isn't correct.


Thanks,
Naveen Nathan

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20031012/aa3a26c1/attachment.htm


More information about the Linux-PowerEdge mailing list