Racadm causes segfault on Debian kernel

Lukas Kubin kubin at opf.slu.cz
Thu Oct 9 01:57:00 CDT 2003


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Wed, 8 Oct 2003, Eberhard Moenkeberg wrote:

> Hi,
>
> On Wed, 8 Oct 2003, Lukas Kubin wrote:
>
> > I'm trying to run racadm (I got from
> > http://domsch.com/linux/openmanage-contrib/debian/) on two, almost
> > identical servers: PE4600, Debian, kernel 2.4.20-3-686-smp.
> > On one of them everything works fine. However the second one gets
> > "Segmentation fault" whe I run "racadm setrac". When I run "racadm
> > racdump", then it only returns the first section (getsysinfo) and also
> > fails with segfault.
> > The same problem appears on our PE2650 with same kernel.
> > Newer kernels didn't work at all.
> > Does anybody know a solution for this? Which kernels do you run on Debian?
> > Thank you.
>
> I guess it is a matter of the libc version - segfaults happen with newer
> versions here.

Hmm. That's bad. I can't downgrade libc. Is there any solution to this?
Should I simply copy an old libc6 file from another machine and force
racadm to use it?
Thank you.

lukas


> Cheers -e
> --
> Eberhard Moenkeberg (emoenke at gwdg.de, em at kki.org)
>
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com
> http://lists.us.dell.com/mailman/listinfo/linux-poweredge
> Please read the FAQ at http://lists.us.dell.com/faq or search the list archives at http://lists.us.dell.com/htdig/
>
>

- -- 
Lukas Kubin

phone: +420596398285
email: kubin at opf.slu.cz

Information centre
The School of Business Administration in Karvina
Silesian University in Opava
Czech Republic
http://www.opf.slu.cz
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (GNU/Linux)
Comment: Made with pgp4pine 1.75-6

iD8DBQE/hQZqhukdIiZrwu4RAoOuAJ9INQI2Zw+BOXMkDcSMwmcu4C9UdwCeKAVw
XxTUy15otcLGIqaTt6cSxOA=
=s9N1
-----END PGP SIGNATURE-----





More information about the Linux-PowerEdge mailing list