Redhat Enterprise ES on a PowerEdge 4300/450

Xose Vazquez Perez xose at wanadoo.es
Thu Oct 2 20:03:00 CDT 2003


James Herschel wrote:

> We're running a PE4300/450 with 256MB of RAM - no PERC card.
> BIOS = 1.10 A01
> ESM = 5.39
> SCSI =
> PSPB =
> SCSI is controlled by a 7890 and a 7860

first step - to update BIOS, ESM/Backplane firmware and maybe SCSI Drives
firmware, sometimes it's necessary RAID firmware too:
http://support.dell.com -> PowerEdge 4400 -> Downloads ->
Select Your Download Category -> All
Select an Operating System -> BIOS
Select the Operating System Language -> English

second step - to apply _all_ Red Hat updates to 7.3:
http://ftp.redhat.com/pub/redhat/linux/updates/7.3/en/os/

> After trying to install RH ES multiple times, I received lots of fun errors
> and scenarios that I tried to work around (I'll detail these at the end).  I

It does not is usual.

> tried installing RH 7.3 (which RH ES is based on) which did not work either
> ... something about not being able to find /dev/sdb.

RHES 2.1 is based on 7.2 + some fixes and new packages of 7.3 + a lot of
patches to a 2.4.9 kernel. And 7.3 gets newer packages and kernel, today,
is a 2.4.20 version, _without_ enterprise features.
As you can see they are very different products.

> -Installing RH ES worked only about 70% of the time ... it would die the
> other 30% with random rpmdb errors.
> -upon reboot the machine would either reboot continuously after initializing
> the SCSI interfaces (GRUB prompt did not appear) or ...
> - upon booting I would receive the error "init: erro while loading shared
> libraries: /lib/i686/libc.so.6: undefined symbol: _nl_current_CC_COLLATE;
> version GLIBC_2.0 kernel panic: Attempted to kill init!"
> -after booting any time with Linux and I noticed another funny pattern - if
> I pulled the power from the machine and rebooted, I would receive the error:
> 	"power supply paralleling board firmware revision 0.0
> 	!! **** Warning: firmware is out of date, please update *****
> 	Warning: Only one power supply is active"
> And then it would continuously reboot after I hit F1 to resume.

Maybe a HW problem ? try to pass DELL tests, at sample place than firmware,
*and* memtes86 http://www.memtest86.com

> I have not received any BIOS errors since installing Windows 2000 even when
> pulling the power.

> Is this a known issue with RedHat 7.3?

PowerEdge 4400 is "Tested and Supported" with "Logo Certfication" to 7.3
http://www.dell.com/us/en/esg/topics/products_os_cert_pedge_004_os_linux.htm
-- 
:x




More information about the Linux-PowerEdge mailing list