time drift (again)

Andy Stubbs andrew.stubbs at activehotels.com
Thu Jan 30 08:00:01 CST 2003


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


Hi,

A few people on this list have been mentioning having problems with time
drift. I've also been experiencing varying degrees of drift on each of our
9 different machines: slowing from a second or so to 20 mins per day.  
Trawling the archives, I've seen it mentioned that some people may think
this is kernel-related (and not perhaps dell overclocking the servers ;) -
although, I suppose they would have to be underclocked to lose time...).

So, I'm trying to come up with a sensible solution to this rather irksome
problem by syncing to the hwclock each night and running ntp to try and
keep this drift at bay. Unfortunately, due to some cunning NAT that we use
on our routers I need to specify which source IP address ntp uses; ntp
seems determined to use the default route, which is no good - I might be
able to reconfigure our routers to get around it, but I'd rather not...).

I suppose my questions boil down to 

(a) does anybody understand this time-drift problem and how I can make it
stop or manage it better. I have 6 dual P 3 machines, 2 up Xeon machines
(with ht enabled) - all running 2.4.18-10smp, and one up P3 machine
running 2.4.18-10. It's one of the Xeons (a PE2600) which is the worst
offender.

or, alternatively

(b) does anybody know how to specify an interface and/or a source IP
address for ntp transmit udp packets on/from?

Regards,

Andy

- -- 
Andy Stubbs, B.A., Ph.D.
Network Manager, Active Hotels Ltd.
+44 1223 578106


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE+OTAXQsxCoxPcZ3QRAgpLAJ9RT1CHQyZa+scEYysEsArrNJEuXgCffSdq
kVuv81AeK1fB7P2R/k4/FKg=
=ydQA
-----END PGP SIGNATURE-----




More information about the Linux-PowerEdge mailing list