1 x 2 Backplane for our Pe2600

jason andrade jason at rtfmconsult.com
Sun Aug 31 23:19:00 CDT 2003


On Mon, 1 Sep 2003, Paul wrote:

> Hit Control-M when its starting the PERC. goto Configure, Hit enter on the
> disk and choose "Format". That took about 17minutes to format a 36gb 15k rpm
> u320

i have no idea why he did this.  i've never heard of anyone needing to
'format' a drive except under diagnostic conditions.  odd (and not inspiring
a great deal of confidence but perhaps someone else can explain why this
might be needed and educate me..)

> They are on the second channel (Channel-B or Channel-1) and are listed in
> the right hand side on the main window. On the left hand side is Channel-A
> or Channel-0 in RAID mode with its 6 disks

hmm, IIRC the pe2600 has a perc3/di ? or maybe a perc4/di which has a dual
channel raid controller.  this means it can have multiple raid channels
(hence the A and B).  you can also 'convert' the channels into 'generic'
scsi channels using an onboard adaptec chipset.

> drives get power. Bios boots OK no errors at POST. Bios lists 1 Logical
> Drive and 2 Physical drives handled by the BIOS. Used to be "1 Logical drive
> handled by BIOS".

ok, so it's seeing drives somewhere.

> > then check that the bios does indeed have the second channel as SCSI (and
> > not raid).
>
> I cant confirm this at the moment as the server is in production and live.
> We tried to create a RAID0 array using the two new disks on the second
> channel. it accepted it all and worked but got an error when i went to save
> the configuration.
> "Error writing configuration. Press any key ton continue" and then array
> disappears after that. Will the PERC bios always let u make an arrray
> regardless of channel mode and then throw an error when u save it?
> I would of thought that I would not even let u choose half of the menu
> options to configure array etc when its in standard scsi mode

i haven't done a huge amount of testing but in my limited testing the
controller will often 'let' you do certain things but fail at the last
step.  so you can get the impression you can do stuff but it actually
fails.  this is of course sometimes hard to test on a production machine..

> OK this could be problem here. As far as I know that kernel (included or
> moduled) doesnt have aic7xxx or any adaptec stuff loaded. It only has the
> Megaraid 1.18f (or h) loaded.
> So in theory I need to load aic7xxx to be able to see the "SCSI mode or scsi
> part" of this? Does this make logical sense? I sort-of does to me now that I
> think about it

well, it's worth a shot and shouldn't break anything.

just run modprobe aic7xxx

if it loads and comes up with the drives then you have verified that the drives
are on a 'scsi' channel and just add the appropriate line to your modules.conf
to see them on startup.

if it doesn't.. then i am guessing the drives are on a 'raid' configured
channel but haven't been configured enough to use by the OS.. e.g they
may need to be initialized as 'volume' or bound in a raid array.

but you seem quite certain they aren't so this is unlikely.

regards,

-jason




More information about the Linux-PowerEdge mailing list