1 x 2 Backplane for our Pe2600

Paul paul at kbs.net.au
Sun Aug 31 23:11:00 CDT 2003


Hi,

Thanks for your reply/help. Here is some bits I've added in, see below

----- Original Message ----- 
From: "jason andrade" <jason at rtfmconsult.com>
To: "Paul" <paul at kbs.net.au>
Cc: <linux-poweredge at dell.com>
Sent: Monday, September 01, 2003 2:01 PM
Subject: Re: 1 x 2 Backplane for our Pe2600


> On Mon, 1 Sep 2003, Paul wrote:
>
> > Dell came out to install a 1 x 2 Backplane for our Pe2600 yesterday and
2 x
> > 36gb disks. The drives were installed in the media bay using their media
bay
> > converter. They were then connected to the second channel on the
motherboard
> > and left in standard SCSI mode. The first channel is in RAID mode with a
> > RAID5 array on it. The dell guy then booted up went to the RAID bios and
> > formatted the two new disks and then restarted the server. At this point
the
>
> if he went into the raid bios to 'format' the disks (what does this mean ?
> he can't low level format the things.. maybe he initialized them ?) then
> they are not on the scsi channel i am guessing, but on the raid channel.

Hit Control-M when its starting the PERC. goto Configure, Hit enter on the
disk and choose "Format". That took about 17minutes to format a 36gb 15k rpm
u320
They are on the second channel (Channel-B or Channel-1) and are listed in
the right hand side on the main window. On the left hand side is Channel-A
or Channel-0 in RAID mode with its 6 disks

>
> > OS booted correctly but it couldn't see the new drives. I found the new
> > backplane which was listed in dmesg and on the bootup screen but the
drives
> > were no where to be found. The OS is SuSe Linux Enterprise Server 8. So
now
> > we have the server running but can't use these two new disks. Is there
> > anything simple I am missing to make this work?
>
> the first thing is to verify the physical cabling to make sure it's all
> ok.  i assume the drives in the media bay power up etc.
>

drives get power. Bios boots OK no errors at POST. Bios lists 1 Logical
Drive and 2 Physical drives handled by the BIOS. Used to be "1 Logical drive
handled by BIOS".

> then check that the bios does indeed have the second channel as SCSI (and
> not raid).
>

I cant confirm this at the moment as the server is in production and live.
We tried to create a RAID0 array using the two new disks on the second
channel. it accepted it all and worked but got an error when i went to save
the configuration.
"Error writing configuration. Press any key ton continue" and then array
disappears after that. Will the PERC bios always let u make an arrray
regardless of channel mode and then throw an error when u save it?
I would of thought that I would not even let u choose half of the menu
options to configure array etc when its in standard scsi mode

> then check to see if you can see the drives as the system/bios level.  the
> hardware should scan through the PERC (onboard) controller first and
> see your raid arrays then the onboard scsi and see any devices connected
> to it.
>

OK this could be problem here. As far as I know that kernel (included or
moduled) doesnt have aic7xxx or any adaptec stuff loaded. It only has the
Megaraid 1.18f (or h) loaded.
So in theory I need to load aic7xxx to be able to see the "SCSI mode or scsi
part" of this? Does this make logical sense? I sort-of does to me now that I
think about it

> e.g perc blah blah
>     aic7xxx blah blah
>
> if you are not seeing the devices at the system/bios level then the OS
will
> not see it either.
>

The BIOS can see them fine

> > I assumed once they were formatted that I could simply fdisk /dev/sdb
and
> > away I go. But this is not the case. Below is stuff from dmesg if this
helps
> > work out whats wrong. Do I need some special compile of the MegaRAID
driver
> > now that I'm using each channel in a seperate mode? I wouldn't have
thought
> > so.
>
> he may have initialized the drives but perhaps they have not been
configured
> as 'Volume' if they are on the raid channel.
>

No volumes were created. The bios wont let u initialize them as its not part
of an arrray. just single scsi disks

> > Attached scsi generic sg1 at scsi0, channel 4, id 6, lun 0,  type 3
> > Attached scsi generic sg16 at scsi0, channel 5, id 6, lun 0,  type 3
>
> hmm, these look like 'scsi generic' devices, not scsi disks. and on
> different channels so i assume they're the 'system' scsi devices.
>
> > Attached devices:
> > Host: scsi0 Channel: 00 Id: 00 Lun: 00
> >   Vendor: MegaRAID Model: LD0 RAID5 86390R Rev: 2.27
> >   Type:   Direct-Access                    ANSI SCSI revision: 02
>
> your PERC raid array.
>
> > Host: scsi0 Channel: 04 Id: 06 Lun: 00
> >   Vendor: PE/PV    Model: 1x6 SCSI BP      Rev: 0.29
> >   Type:   Processor                        ANSI SCSI revision: 02
>
> the backplane scsi
>
> > Host: scsi0 Channel: 05 Id: 06 Lun: 00
> >   Vendor: PE/PV    Model: 1x2 SCSI BP      Rev: 1.1
> >   Type:   Processor                        ANSI SCSI revision: 02
>
> the second backplane scsi
>
>
> no sign of any disks..
>

If I had a system with megaraid 1.18f in the kernel and no other adaptec
stuff (ie: aic7xxx) would I have this problem? Being able to see the
backplane but no drives there?

>
> regards,
>
> -jason
>

Thank you for your valuable help




More information about the Linux-PowerEdge mailing list