Question installing OMSA 1.4

Álvaro Palma apalma at custodium.com
Thu Aug 28 21:15:01 CDT 2003


I'm trying to install OMSA 1.4 in RedHat 7.2 kernel-2.4.20-20.7custom
(custom compiled) but if I run: 

sh start.sh -dcheck

I get in /var/tmp/esm.map:

/lib/modules/2.4.20-20.7custom/misc/esm.o: kernel-module version
mismatch
/lib/modules/2.4.20-20.7custom/misc/esm.o was compiled for kernel
version 2.4.20-20.7 while this kernel is version 2.4.20-20.7custom.

And, in fact, if I take a look in
/lib/modules/2.4.20-20.7custom/misc/esm.o, it says kernel-2.4.20-20.7

Is there a way to recompile esm.o module to reflect the real kernel I'm
using? Running standard kernel (2.4.20-20.7) is not an option. I tried
to manually change the kernel version in esm.o (don't laugh!) but
obviously doesn't work...

Thanks a lot for your attention.

-- 
Atte.
Álvaro Palma




More information about the Linux-PowerEdge mailing list