test results: trying to grow a container

jason andrade jason at rtfmconsult.com
Tue Aug 26 23:11:01 CDT 2003


Hi,

I decided to do some testing to the issue of trying to
'grow' a container by replacing drives with larger sized
ones.

summary: i can't see any way to do it, at least not with
         a mirrored container.  i doubt it will be different
         with raid5

I created a RAID1 mirror set using 2 9G drives.  installed
redhat linux 9 on it and then used the afacli tools.

i offlined slot1 and replaced the 9G drive with a 73G drive.

the system rebuilt fine onto it.  it sees it as a 73G drive
and it used 9G of capacity on it to rebuild.

i then offlined slot0 and replaced the remaining 9G drive
with a 73G drive.  the system rebuilt fine again and i
now had 2 73G drives in RAID1.  however the container is
still 9G in size (8.47G specifically) and i cannot see
any way to 'grow' it.  i also cannot see any way to create
'another' container using the free space.

if you go into the console (controller) bios you can
'see' the extra disk space but if you try to use it
in any way you will find the controller gives you
an error.  it did this no matter whether i tried to
use one or both drives and whether i tried to create
a container as a volume, stripe or mirror.

this is using the perc2/si controller on a PE2400.. i doubt
it would be any different on the perc3/si or perc3/di.

regards,

-jason




More information about the Linux-PowerEdge mailing list