bcm5704 Driver disk for RedHat 7.3

JACOB_LIBERMAN@Dell.com JACOB_LIBERMAN at Dell.com
Fri Aug 8 16:59:00 CDT 2003


Sam,

You might need to include the boot controller by following the same steps.
Use the steps below as a general guideline. Download the broadcom 6.7.1
kernel source and compile it against the boot kernel.

If you need more detailed instructions please reply to me directly.

Thanks,

Jacob

######################################################

Before you start:

mkdir /mnt/floppy2 # will need a few things mounted 
rpm -Uvh /mnt/cdrom/RedHat/RPMS/kernel-BOOT-2.4.18-3.i386.rpm # install the
boot kernel modules, if not already done. It's on disk2 of your Red Hat
installation media. 
Get a blank floppy. 
Download the latest broadcom driver and extract the compressed file or
install the rpm and copy the bcm5700.o to a convenient location. Preferably
/temp in this case. 
 

Actual Process:

mkdir /temp 
cd /temp # just somewhere to work 
mount /mnt/cdrom # mount the cdrom so you can get the boot image 
cp /mnt/cdrom/images/bootnet.img  /temp. # this is the native 7.3 network
boot diskette image. 
dd if=bootimg.net of=/dev/fd0 # make sure you have a floppy in the drive.
This will create a boot diskette. 
mount /mnt/floppy # you should now be able to see the contents of what was
the bootnet.img if you list the contents of /mnt/floppy. Make sure you go
back to /temp if you do so before continuing. 
cp /mnt/floppy/initrd.img /temp. # get the initial ramdisk image out of the
disk image 
gzip -dc initrd.img > initrd.data # decompress it 
mount -o loop initrd.data /mnt/floppy2 # mount the ramdisk so you can access
it's contents. 
cp /mnt/floppy2/modules/modules.cgz /temp. # so you have a working copy of
the compressed modules. 
gzip -dc modules.cgz > modules.cpio  # extract the modules, which hide in a
compressed cpio 
cpio -idv < modules.cpio # extract the modules in the ramdisk, they will
open to a 2.4.18-3BOOT directory 
rm -f 2.4.18-3BOOT/3c59x.o # make space by deleting the 3COM driver and any
others you know you don't need. 
cp -p /drivers/bcm5700.o  2.4.18-3BOOT/ # Put the broadcom module in with
the other modules. The source of your driver will vary depending on where
you get it from as mentioned earlier, but it should be in a network-install
folder in the bcom driver download. 
find 2.4.18-3BOOT -print -depth | cpio -ov -H crc > modules.cpio #
regenerate the cpio archive in the correct format 
gzip -c9 modules.cpio > modules.cgz # and compress it 
cp -p modules.cgz  /mnt/floppy2/modules # Put your compressed modules back
in the image. 
vim /mnt/floppy2/modules/module-info # edit the entry for the 3c59x to be
for bcm5700 and a text description. 
vim /mnt/floppy2/modules/pcitable # from the editor add the following and
save: 
0x14e4       0x1644            "bcm5700"       "Broadcom NetXtreme BCM5700
Gigabit Ethernet"

0x14e4       0x1645            "bcm5700"       "Broadcom NetXtreme BCM5701
Gigabit Ethernet"

0x14e4       0x1646            "bcm5700"       "Broadcom NetXtreme BCM5702
Gigabit Ethernet"

0x14e4       0x16a6             "bcm5700"       "Broadcom NetXtreme BCM5702
Gigabit Ethernet"

0x14e4       0x1647            "bcm5700"       "Broadcom NetXtreme BCM5703
Gigabit Ethernet"

0x14e4       0x16a7             "bcm5700"       "Broadcom NetXtreme BCM5703
Gigabit Ethernet"

umount /mnt/floppy2 # unmount the initrd.data now that you're done with it. 
gzip -c9 initrd.data > initrd.img # compress the ramdisk back into image
format. 
cp -p initrd.img /mnt/floppy # copy the modified ramdisk image back onto
your floppy disk. 
umount /mnt/floppy # unmount the floppy disk 
dd if=/dev/fd0 of=/temp/bootnet.img # You now have a new boot disk image
with broadcom gigabit support. 

-----Original Message-----
From: Salvatore J. Guercio Jr. [mailto:sguercio at ccr.buffalo.edu] 
Sent: Friday, August 08, 2003 4:09 PM
To: Linux-PowerEdge
Subject: bcm5704 Driver disk for RedHat 7.3


Dear List,

Does anyone know where I can get a driver for the bcm5704 that will work 
with the 2.4.18-3BOOT kernel? The reason I am in need of this is because 
we are evaluating a few 1750s and I need to be able to kickstart them 
over the network to RedHat 7.3. and the tg3 driver and the bcm5700 
driver that came with the 7.3 boot images do not seem to support these 
cards.

I tried to build the bcm5700 driver for the 2.4.18-3BOOT kernel but I 
keep getting unresolved symbols when I try to insert the module.

Once the kickstart installation is over I do drop my own kernel on as 
part of the post install which does support the 5704 with the tg3 just 
fine. I have tried rebuilding the anaconda images to no avail because it 
seems the newer kernels are too large for the allocated space by 
buildinstall and it just craps out.

Has anyone had any luck netbooting a 1750 to a Redhat 7.3 with the 
bcm5704 cards?

Help is greatly appreciated.

Thanks

~Sam

-- 
Salvatore J. Guercio Jr.            http://www.ccr.buffalo.edu
Sr. Programmer Analyst              sguercio at buffalo.edu
Center for Computational Research
9 Norton Hall
Amherst, NY 14260
(716)645-6500


_______________________________________________
Linux-PowerEdge mailing list
Linux-PowerEdge at dell.com
http://lists.us.dell.com/mailman/listinfo/linux-poweredge
Please read the FAQ at http://lists.us.dell.com/faq or search the list
archives at http://lists.us.dell.com/htdig/




More information about the Linux-PowerEdge mailing list