Megaraid help

Tom Lesniak TLesniak at lyrix.com
Mon Aug 4 16:34:00 CDT 2003


My configuration:

PE2600
RH7.2  2.4.9-13 (i know it's old but i'm forced to use this kernel so I
can't upgrade)
megaraid v1.18c (currently running)
512 Meg Ram

I found out that megaraid v1.18c will not work with 1GB Ram. (crashes on
boot)

So I downloaded the latest megaraid driver (1.18i) and installed it.
(in order for me to compile the driver i had to edit the megaraid.h file
and change 'highmem_io' to 'can_dma_32')

This works fine with 512M ram so I upped it to 1GB, and it boots up
normally.

I wanted to do some testing of the driver so i created a 300M file and a
500M file in one of my filesystems.  I then copied the 300M file to a
different filesystem. It worked with no problems.  So I then tried to copy
the 500M file to another filesystem and i got a kernel panic.

     Kernel Panic : DMA pool exhausted
     In interrupt handler - not syncing

This hung the system, so i was forced to reboot.
I repeated the above test several times, each ending in the kernel panic.
(i'm not filling up the filesystems, i've got plenty of space)

Any ideas as to what is causing this and how to fix it??
Any and all help is greatly appreciated.

I also tried the above with v1.18j of the megaraid driver and I got the
same results.

     - Tom





More information about the Linux-PowerEdge mailing list