Install RHEL 2.1 ES update 2 on Dell PowerEdge 1750?

Graham Freeman graham at jahiel.net
Sat Aug 2 17:29:01 CDT 2003


Hi folks,

Software: Red Hat Enterprise Linux ES (v. 2.1 for i386) Update 2

Hardware: Dell PowerEdge 1750 (BIOS A05) with Dell PERC 4/Di (LSI-based)  
v4.04

Red Hat Error Message(s): An error has occurred - no valid devices were
found on which to create new filesystems.  Please check your hardware for
the..

Problem summary:

I'm attempting to install RHEL 2.1 (ES edition) update 2 on a new Dell
PowerEdge 1750 with a Dell/LSI PERC 4/Di SCSI RAID controller.  The PE1750
BIOS is at level A05, which is the most current from Dell.  The PERC 4/Di
firmware is at 4.04, which also the most current available from Dell.
 
Disc 1 of RHEL 2.1 update 2 apparently doesn't load the appropriate
(megaraid?)  driver, because after I select the type of partitioning
(whether it's manual or automatic) I'm given the aforementioned error.  
("An error has occurred - no valid devices were found on which to create
new filesystems...")
 
Browsing the linux-poweredge at dell.com list, I see that Peter Hanusiak
experienced a similar problem with Red Hat 7.3 and a PowerEdge 1750.  He
apparently fixed it by creating a driver disk from LSI Logic's web site.  
I tried this without success.  (Maybe I didn't do it correctly.  It's also
possible that the RH 7.3 driver from LSI isn't appropriate for RHEL 2.1.)
 
Any/all advice would be greatly appreciated.  I also have a ticket open
with Red Hat support.  Thanks.

-Graham




More information about the Linux-PowerEdge mailing list