Upgrading PE4400 from RH7.0 to RH7.3?

Brian Kasper Brian.P.Kasper at aero.org
Fri Aug 1 19:23:01 CDT 2003


Greetings!

Long-time Linux admin, first time list poster.

I have a PE4400 with a PERC/3Di RAID controller hosting a single, 
4-drive 100GB RAID 5 container.  I'm using a PowerVault 120T-AL for my 
tape backup system. 

I received the system in 2001 with RH7.0 pre-installed.  I'm looking to 
update to RH7.3, but I've not been able to find a description of the 
requirements (BIOS versions, etc.) and the steps required for this 
process.  I've been applying updates via up2date as they became 
available (the only one I haven't installed yet is the 2.2.24 kernel), 
but I've never flashed my BIOSes so they're all still 2001 vintage.

My plan is to purchase the RH7.3 CDs from Dell and use them to perform 
the install.  I would really appreciate it if anyone can help me with 
the following questions:

1) How can I determine the relevant BIOS revisions in the system without 
powering it off?  It's currently in very heavy use and I'd prefer to 
avoid downtime.
2) Once I know my BIOS revs, what versions are required for RH7.3?
3) I think I might need to update the BIOSes for the system, RAID 
controller, and PowerVault.  Are there any others about which I should 
be concerned?
4) When I perform the upgrade, how can I tell if I have a Utility 
Partition on my drive and how do I avoid clobbering it with GRUB?  Is it 
as simple as not installing GRUB into the boot partition?
4a) If I upgrade 7.0 to 7.3 and switch to GRUB, does the system boot 
process need to be reconfigured to launch GRUB rather than LILO?
4b) Or can I simply keep my current LILO-based boot process?
5) In general, is the upgrade process as straightforward as booting from 
the CD-ROM and following prompts?  Are there any special gotchas?
6) I've installed the Bastille hardening script on the system; is anyone 
aware of incompatabilities between RH7.0 and RH7.3 for Bastille Linux?

Sorry for the grab-bag of questions, but I really really need to do my 
homework on this one, as if the system goes down I have many unhappy 
people to answer to. 

I'm performing this upgrade because I believe that the latest version of 
our tape backup software (BrightStor ARCServe Backup for Linux, nee 
ARCServeIT for Linux) needs at least 7.3 and because I think the 2.4.x 
kernel will be more efficient with this system than the 2.2.x series.

Thanks in advance for your time and consideration.

-Brian Kasper
 The Aerospace Corporation
 kasper at aero.org





More information about the Linux-PowerEdge mailing list