PE2650 + RHL7.3 (2.4.17-17.7.xsmp) issues and experience

Brian J. Smith-Sweeney bsweeney at physics.ucsb.edu
Wed Nov 27 17:05:00 CST 2002


Greetings all,

I'm new to thislist, having just bought a PowerEdge 2650, and thought
I'd share my experience and ask a few questions.  I apologize in advance
for the rather lenghthy remainder of this post.

First, getting the RAC/Server Administrator stuff working with the
latest RedHat kernel took some work.  The Server Administrator cd only
has precompiled esd modules for a few kernels, and will attempt the
"dynamic kernel" compilation for any other.  Unfortunately, that dcesm.c
file includes linux/malloc.h, which has been deprecated.  To further
complicate matters, despite the fact that the malloc.h file includes the
proper slab.h file within itself, it still reports an error instead of a
warning when you include it.  Therefor, the dcesm module won't compile,
and the ServerManager install fails claiming it can't support my
kernel.  Since the source for the module actually comes in the
dellomsa-drivers rpm and is not easily compiled/installed seperately,
the only way I got the install process to work was to comment the #error
out of my malloc.h file.  I don't really like messing with the kernel
headers that way, but I couldn't figure any other way to get the
installer to work.

After the install, the OpenManager web interface worked pretty well
(albeit only from a windows IE client, but I think that's been discussed
on this list already), but occasionally it wouldn't be listening on the
1311 port.  I ran the /etc/delloma.d/omastart.sh manually a couple of
times, and now it seems to start the webserver after each reboot.  Don't
know why that was flaky before though.  Now that it is running properly,
however, I noticed that there are something like 50 omaws32 processes
running; anyone know why there are so many?

Since the IT assistant stuff doesn't seem to run on a linux box, I
installed it on a windows system; haven't messed with it too much yet
though.

So, the only remaining issue is as follows:  when I attempt to connect
to the server in question directly via the RAC ethernet port  on its
private ip address via http, it begins to load java on the client
browser and then it appears to redirect the client to localhost. This
fails, since the client isn't running any special software.  I have
confirmed this behavior on both windows and linux boxes running 
netscape and IE (both recent versions).  To be certain, I sniffed the
loopback interface on the linux client and sure enough every time I
connect to the server, I begin loading the java applet and suddenly a
bunch of high port connections show up on the loopback interface, and I
get an error like "connection reset by peer".  I asked Dell about this,
and was advised to reflash the RAC firmware which did not help.  I also
tried reconfiguring the RAC ip via the BIOS to grab an ip on my network
via dhcp, but that didn't help either.

So, that's my experience with it thus far.  If anyone has suggestions
regarding the RAC NIC, I'd appreciate them.  Hope everyone in the US has
a good thanksgiving.

-Brian

========================================
Brian Smith-Sweeey
Senior Systems Administrator
University of California, Santa Barbara
Physics Department
bsweeney at physics.ucsb.edu
(805)-898-9704





More information about the Linux-PowerEdge mailing list