OMSA & aacraid / afasnmpd

Michael Markstaller mm at elabnet.de
Thu Nov 21 06:23:00 CST 2002


First of all thanks, after removing and reinstalling snmp (4.2.5), omsa
and dependent libraries, OMSA and snmpd now work both, but in snmpd.conf
there were really no lines with "pass" or something like that. Somehow
snmpd took the wrong config-path/files I think..

Regarding net-snmp, I think I can wait for the Redhat package, besides
that while googling around a bit I found that it seems some
nagios-plugins still seem to have some problems with 5.x.

One problem remains, what I wanted to poll via SNMP initially was the
Perc3/Si array status and counters if possible. I tried with
afasnmp-2.7-1.i386.rpm and I'm sure it also somehow worked once to get
values under oid enterprises.975 but after this first try never again,
even with reinstalling several times, restarting daemons etc.. 
I think this question was also asked several times before here but never
answered, the documentation for afasnmp is very thin, the only document
I found on the dell-site says "equires UCD SNMP version 4.1.1 (and only
this version)."
Is this true ? 
I added "master  agentx" to snmpd.conf (I guessed this is then required
for afasnmpd) and also tried with net-snmp-5.0.6 as snmpd agent, always
with the same result, no output under oid enterprises.975 (but also no
crashes). It seemed just like afasnmpd doesn't talk with snmpd. I gues
there's some config-entry or similiar missing, does anybody got afasnmp
running successfully ?

Michael

-----Original Message-----
From: Joshua_Giles at Dell.com [mailto:Joshua_Giles at Dell.com] 
Sent: Thursday, November 21, 2002 12:00 AM
To: Michael Markstaller; Joshua_Giles at Dell.com; linux-poweredge at dell.com
Subject: RE: OMSA & SNMPd dead




>>maybe a very dump question: how can I find out which subagents are
>>installed for ucd-snmp ? At least I didn't find anything in
>>/etc/snmp/snmpd.conf besides the smuxpeer-entry.

No lines begining with "pass"?


>>Regarding net-snmp: I don't really want to download and install
>>something outside redhat RPM's because of automatic updates and
>>compatibility issues but if it helps me I'll try. Is it the "same" as
>>ucd-snmp, is there anything to be considered ? 

It follows all of the SNMP standards;just like it's predecessor.  I
suggest
using the net-snmp 5.0.6 release from SourceForge for testing.
Additionally, Red Hat is due to release a errata for net-snmp that is
based
upon 5.0.6 in a couple weeks.

>>Also there're many mrtg and a big nagios (netsaint) installation
running
>>on this box, using several perl snmp-modules from cpan to gather
remote
>>data. Will this get affected anyhow if I change the ucd-snmp to
net-snmp
>>? 
I haven't seen any issues specific to perl modules on the net-snmp
mailing
list.  
Also, try using gdb to see where snmpd crashes.


-----Original Message-----
From: Joshua_Giles at Dell.com [mailto:Joshua_Giles at Dell.com] 
Sent: Tuesday, November 19, 2002 10:17 PM
To: Michael Markstaller; linux-poweredge at exchange.dell.com
Subject: RE: OMSA & SNMPd dead


Michael,

Are there any other SNMP subagents on the system?  Perhapts adaptec or
LSI
based?  If so, try stopping those and then re-trying the query.  I would
also suggest using a newer version of snmp from
sourceforge(net-snmp-5.0.6
is pretty stable).

Read ya,

Joshua Giles



-----Original Message-----
From: Michael Markstaller [mailto:mm at elabnet.de]
Sent: Tuesday, November 19, 2002 1:31 PM
To: linux-poweredge at exchange.dell.com
Subject: OMSA & SNMPd dead


Hi,

after installing OMSA (with dynamic kernel-driver, after trying and
reading a few hours) dellomsa-drivers-4.70-3613, dellomsa-4.70-3613 from
APP32_LNX_MN my snmpd is dead now. I already tried to remove the
mux-entry from /etc/snmp/snmd.conf with the same result, it dies on the
first query.. Any hints ? 
It's a PE2450, Perc3/Si with RH 7.1 latest RH-kernel 2.4.18-18.7.xsmp
and ucd-snmp-4.2.5-7.71.0.rpm from RH. The system is standard redhat
with latest packages installed (and I won't change this to something
so-much-better-self-compiled, I'm happy with binaries and automatic
updates)

Also, from the W2k OMSA I'm used to get the storage/raid status via
snmp, which was the initial reson to start this
installation-compilation-desaster; is this possible somehow ? The
afasnmp-2.7-1.i386.rpm at least dind't work at all. 

Despite I'm asking myself how linux should ever get something really
usable when it's even impossible to setup simple server-agents without
downloading hundreds of MB of kernel-sources and dealing with such
stuff. I've missed setup.exe and the continue-button today ;)


Thanks for your help

Michael Markstaller

_______________________________________________
Linux-PowerEdge mailing list
Linux-PowerEdge at dell.com
http://lists.us.dell.com/mailman/listinfo/linux-poweredge
Please read the FAQ at http://lists.us.dell.com/faq or search the list
archives at http://lists.us.dell.com/htdig/





More information about the Linux-PowerEdge mailing list