problem installing OMSA Dynamic Kernel Support with RH 2.4.18 -17.7.x kernel

Ben Strong bstrong at betlo.com
Wed Nov 13 00:15:01 CST 2002


Hi,

I'm trying to follow Steve's instructions on a new PE 1650 with
2.4.18-17.7.x on 7.3. Everything is fine up until the last step
(start_text.sh). When I run it I get the original error again:

---

# ./start_text.sh 
Turning off DMA on IDE CDROM drives.
Disabling DMA for CDROM /dev/hda
Message: [Start] -> Please wait
./sysid: error while loading shared libraries: libdchapi32.so.4: cannot
open shared object file: No such file or directory
Checking Dependencies...
Installation failed : Server Administrator does not support the running
kernel.
See the Server Administrator readme file for more information.

---

Should this really work, or do these instructions assume that you did
the original install before upgrading the kernel? Will manually
installing /sa47/linux/ServerAdministrator-1.0-0.i386.rpm give me
everything I need?

Thanks,
Ben Strong

---------------------

> 3. Either edit file
> /usr/lib/dell/openmanage/omsa/drivers/open_src/esm/dcesm.c or copy
over the
> attached file into the directory and overwrite the one that is there.
If
> you edit it, change malloc.h  and vmalloc.h to slab.h and then go to
the
> /usr/lib/dell/openmanage/omsa/bin and run './dellomsaesm start' and
will
> build the driver and the server administrator driver completely and
after
> this run the ./start_text.sh and will install the rest of the
utilities such
> as the webserver and will complete and everything will be running.

> Steve Boley
> Dell Enterprise Expert Center
> Senior Network Technician/Analyst
> Poweredge, PowerApp, PowerConnect, 
> and PowerVault Trained Technician




More information about the Linux-PowerEdge mailing list