Power Supply Fan / OMSA question / New kernel

ジム・キャロウェイ carraway at nexus.co.jp
Wed Jun 12 21:13:01 CDT 2002


Hi Matt & Steve -

Thanks for quick reply.  I was happily surprised when I got into 
work this morning.  

Well, to answer some of your questions, yes, I did upgrade the 
kernel-sources to 2.4.9-34, yes, the esm is version 5.24, but no
on the bios.  Currently, it's version a05, which I'm assuming
was factory installed.  Can't get to NTT until next week, so
when I do upgrade the BIOS, I'll let you know how it turns out.

Anyways, last night thinking that the drivers might 
not have been rebuilt properly I uninstalled and then reinstalled
dellomsa-drivers-4.51-3417, dellomsa-4.51-3417, but no such luck.

Also, the current location of the esm.o driver for 2.4.9-34 is 
different than for previous kernels.  It looks like through kernels
version 2.4.7 the drivers were stored in 
/usr/lib/dell/openmanage/omsa/drivers/2.4.7-XX/smp,
but from 2.4.9 they are stored in /lib/modules/2.4.9-XXsmp/misc/,
is that right?  I haven't upgraded the OMSA packages, since I can't find any.
I did find the upgrade referencing the ECC issue, but that seems unrelated.
However, there are also two packeages regarding that upgrade, 
omsa4xxc-lnx-a00.tar and sa1xxc-lnx-a00.tar.  I'm assuming that they
are the same thing since they are the same size and refer to the same problem.

Also, Steve, you mentioned Server Administrator 1.1, how can
I get a hold of it?  I dug through Dell site and came up 
empty-handed.  After doing a search on Google though, I was led
back to Dell's site, where I found the documentation for it.
Any suggestions as to how to get it?

Again, thanks for the help.

Jim


Matt_Domsch at Dell.com さんは書きました:
>> using varioius tools.  Anyways, after upgrading the kernel 
>> from 2.4.9-31smp to 2.4.9-34smp today using the 
>> Red Hat Network, I got the following errors.  In the past, 
>> upgrading the kernel never resulted in errors.
>
>Did you also upgrade kernel-sources?  If not, then the esm.o driver won't
>get rebuilt properly, thus can't feed good data to applications.
>
>Thanks,
>Matt
>
>--
>Matt Domsch
>Sr. Software Engineer
>Dell Linux Solutions www.dell.com/linux
>Dell internal Linux lists @ http://insidelists.us.dell.com
>Dell public Linux lists @ http://lists.us.dell.com
>#1 US Linux Server provider for 2001 and Q1/2002! (IDC May 2002)
>
>

Steve_Boley at Dell.com さんは書きました:
>Try upgrading the server administrator to 1.1 version and see if the errors
>clear up.  Also what version of the esm is loaded on the system?  This is
>the actual software running on the motherboard that the sensors are
>controlled by, if wrong version can cause these types of errors as well.
>The esm for the 2450 should be 5.24 and the bios a07.
>Steve
>
>-----Original Message-----
>From: carraway at nexus.co.jp [mailto:carraway at nexus.co.jp]
>Sent: Wednesday, June 12, 2002 2:34 AM
>To: linux-poweredge at exchange.dell.com
>Subject: Power Supply Fan / OMSA question / New kernel
>
>
>Just wondering if anybody knew what was going on or could steer me in the
>right direction to get this problem solved.
>

**************************************************
株式会社ネクサス
システム本部情報システム部情報サービス課
〒540-0011 大阪市中央区農人橋 1-1-22 大江ビル3F
電話 06-6920-0375 FAX 06-6920-0315
ジム・キャロウェイ  carraway at nexus.co.jp
**************************************************




More information about the Linux-PowerEdge mailing list