aacraid AAC error messages being clipped

Matt_Domsch@Dell.com Matt_Domsch at Dell.com
Tue Apr 30 14:14:00 CDT 2002


> and system configuration options. The kernel is 2.4.9-13 and 
> does not have any aacraid patches applied to it.

You *don't* want to be running that kernel.  2.4.9-21 has a better aacraid
driver, and 2.4.9-31 has the current aacraid driver.  Coincidentally, the
'clipped messages' bug was fixed in both of those errata kernels.  Also
solved in these is the highmem bug whereby the controller wouldn't hang the
system just because a buffer it was moving happened to reside >1GB.

> The kernel version cannot be changed due to special 
> requirements related to other drivers in the system.

afacli can be used to get the actual messages back, and if you dig through
the linux-aacraid-devel archives, you should be able to find the patch to
rx.c that fixes the printf messages.  But really, you should seriously
consider running a kernel other than 2.4.9-13.

Thanks,
Matt

--
Matt Domsch
Sr. Software Engineer
Dell Linux Solutions www.dell.com/linux
Linux on Dell mailing lists @ http://lists.us.dell.com
#1 US Linux Server provider for 2001!




More information about the Linux-PowerEdge mailing list