X Server problems

Roddy McColl roddy at physicsgate.swmed.edu
Sun Apr 28 15:21:00 CDT 2002


Another data point, which I found applied to me with a box that had
been upgraded from 6.2 to 7.0 to 7.2. While the xfs server was
started and running fine, it appeared that FontPath entries in
the /etc/X11/XF86Config file override the work of the xfs, unless
you make sure there is a line in /etc/X11/XF86Config that says

 FontPath   "unix/:7100"

I found that when I removed all FontPath entries from this file and
replaced them with the line above, all my font problems disappeared.

There is also some stuff on the Web if you hunt it down about this
being a known problem with RH, i.e. that the XF86Config file is not
updated properly at the transition to using xfs by default.

-roddy

----------------------------------------------------------------------

Return-Path: linux-poweredge-admin at dell.com 
Received: from swtx163.swmed.edu ([199.165.152.163])
	by visual-ra.swmed.edu (8.9.2/8.9.2) with ESMTP id MAA14113
	for <roddy at visual-ra.swmed.edu>; Sat, 27 Apr 2002 12:47:27 -0500 (CDT)
Received: from CONVERSION-DAEMON.swtx163.swmed.org by swtx163.swmed.org
 (PMDF V6.1 #38580) id <0GV807501MG2GV at swtx163.swmed.org> for
 roddy at visual-ra.swmed.edu (ORCPT roddy at physicsgate.swmed.edu); Sat,
 27 Apr 2002 12:40:50 -0500 (CDT)
Received: from physicsgate.swmed.edu (physicsgate.swmed.edu [129.112.25.16])
 by swtx163.swmed.org (PMDF V6.1 #38580)
 with ESMTP id <0GV806VP4MG25T at swtx163.swmed.org> for roddy at visual-ra.swmed.edu
 (ORCPT roddy at physicsgate.swmed.edu); Sat, 27 Apr 2002 12:40:50 -0500 (CDT)
Received: from swtx163.swmed.edu (swtx163.swmed.edu [199.165.152.163])
	by physicsgate.swmed.edu (8.8.7/8.8.7) with ESMTP id NAA28019	for
 <roddy at physicsgate.swmed.edu>; Sat, 27 Apr 2002 13:34:32 -0500
Received: from CONVERSION-DAEMON.swtx163.swmed.org by swtx163.swmed.org
 (PMDF V6.1 #38580) id <0GV807501MG1L3 at swtx163.swmed.org> for
 roddy at physicsgate.swmed.edu; Sat, 27 Apr 2002 12:40:49 -0500 (CDT)
Received: from lists.us.dell.com ([143.166.224.162])
 by swtx163.swmed.org (PMDF V6.1 #38580)
 with ESMTP id <0GV807342MG0IN at swtx163.swmed.org> for
 roddy at physicsgate.swmed.edu; Sat, 27 Apr 2002 12:40:48 -0500 (CDT)
Received: from lists.us.dell.com (localhost.localdomain [127.0.0.1])
	by lists.us.dell.com (8.11.6/8.11.2) with ESMTP id g3RHe3d21802; Sat,
 27 Apr 2002 12:40:03 -0500
Received: from smtp1.us.dell.com (smtp1.us.dell.com [143.166.224.25])
	by lists.us.dell.com (8.11.6/8.11.2) with ESMTP id g3RHd3d21785	for
 <linux-poweredge at lists.us.dell.com>; Sat, 27 Apr 2002 12:39:03 -0500
Received: from shodan.reznet.uleth.ca (shodan.reznet.uleth.ca [142.66.75.205])
	by smtp1.us.dell.com (8.12.1/8.12.1) with ESMTP id g3RHdSbN014691	for
 <Linux-PowerEdge at dell.com>; Sat, 27 Apr 2002 12:39:28 -0500
Received: from [142.66.73.227] (helo=ludwig)	by shodan.reznet.uleth.ca with
 smtp (Exim 4.04)	id 171W9z-0006F4-00; Sat, 27 Apr 2002 11:38:59 -0600
Date: Sat, 27 Apr 2002 11:39:02 -0600
From: Aly Dharshi <aly.dharshi at uleth.ca>
Subject: Re: X Server problems
Sender: linux-poweredge-admin at dell.com
To: Marc Schmitt <schmitt at inf.ethz.ch>
Cc: Linux-PowerEdge at dell.com
Errors-to: linux-poweredge-admin at dell.com
Message-id: <003701c1ee12$6bd0c2b0$e349428e at ludwig>
Organization: University of Lethbridge
MIME-version: 1.0
X-MIMEOLE: Produced By Microsoft MimeOLE V6.00.2600.0000
X-Mailer: Microsoft Outlook Express 6.00.2600.0000
Content-transfer-encoding: 7BIT
X-Priority: 3
X-MSMail-priority: Normal
Precedence: bulk
X-Spam-Status: No, hits=-100.0 required=5.0 tests=A_FROM_IN_AUTO_WLIST
 version=2.01
X-BeenThere: linux-poweredge at dell.com
X-Mailman-Version: 2.0.9
X-Original-Date: Sat, 27 Apr 2002 11:39:02 -0600
References: <1869.142.66.20.43.1019874598.squirrel at webmail.uleth.ca>
 <3CCA7089.1060706 at inf.ethz.ch>
List-Post: <mailto:linux-poweredge at dell.com>
List-Subscribe: <http://lists.us.dell.com/mailman/listinfo/linux-poweredge>,
	<mailto:linux-poweredge-request at dell.com?subject=subscribe>
List-Unsubscribe: <http://lists.us.dell.com/mailman/listinfo/linux-poweredge>,
	<mailto:linux-poweredge-request at dell.com?subject=unsubscribe>
List-Archive: <http://lists.us.dell.com/pipermail/linux-poweredge/>
List-Help: <mailto:linux-poweredge-request at dell.com?subject=help>
List-Id: Linux on Dell PowerEdge Servers discussion <linux-poweredge.dell.com>
Content-Type: text/plain; charset=iso-8859-1
 version=2.01
 <3CCA7089.1060706 at inf.ethz.ch>
	<mailto:linux-poweredge-request at dell.com?subject=subscribe>
	<mailto:linux-poweredge-request at dell.com?subject=unsubscribe>
Content-Length: 2747

All,

    Before I left for the weekend, I checked to make sure that the service
xfs was running, oddly enough the gdm manager is running and if you HUP it,
it try's to restart but with no avail. Then is dies with the font not found.
An odd thing is that during the Xconfigurator setup the windows system gets
tested and works and it sets it to start upon boot and all that fun-do
stuff, exit the program and try testing by startx and boom that error pops
up.

    Thank you for the tmp and the rest of the ideas, but since that server
is not accessible from home it will have to be Sunday or Monday before I can

A
give some ideas a try. But please keep suggesting, if anything pop's into
your mind please let me know. It would be good to know why all the kernels
feel the same way !!

    Cheers,

        - Aly -


------------------
Aly Dharshi
System Administrator ORS
aly.dharshi at uleth.ca
aly.dharshi at cs.uleth.ca

Got *nix ? *nix the better alternative to Winblows


----- Original Message -----
From: "Marc Schmitt" <schmitt at inf.ethz.ch>
To: "Aly Dharshi" <aly.dharshi at uleth.ca>
Cc: <Linux-PowerEdge at dell.com>
Sent: Saturday, April 27, 2002 3:34 AM
Subject: Re: X Server problems


> Hi Aly,
>
> Is the font server (`service xfs status`) running?
> If not, check if /tmp is full, that`s a common problem for the xfs not
> to start.
>
> Regards,
> Marc
>
> Aly Dharshi wrote:
>
> > Hello All,
> >
> >      We have the latest Linux RH 7.2 kernel from RH, we rebooted a 1550
> > with a Dell flat screen 1503FP, and we haven't been able to connect to
the
> > X server aka no X windows running.
> >
> >      The logs in /var/log/XFree86.0.log says the following line before
> > failing to connect.
> >
> >       Fatal server error:
> >       could not open default font 'fixed'
> >
> >      Any ideas ?
> >
> >      Cheers,
> >
> >        Aly.
> >
> > PS: We have tried to roll back as far as the original kernel but with no
> > luck/success. We also tried a Dell E551 monitor (CRT) with the same
> > problems. We tried the Xconfigurator to do the reconfigs but same
results.
> > Also tried generic settings using Laptop panel setting and no change in
> > results.
> >
> >
> >
> >
>
>
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com
> http://lists.us.dell.com/mailman/listinfo/linux-poweredge
> Please read the FAQ at http://lists.us.dell.com/faq or search the list
archives at http://lists.us.dell.com/htdig/
>

_______________________________________________
Linux-PowerEdge mailing list
Linux-PowerEdge at dell.com
http://lists.us.dell.com/mailman/listinfo/linux-poweredge
Please read the FAQ at http://lists.us.dell.com/faq or search the list archives at http://lists.us.dell.com/htdig/




More information about the Linux-PowerEdge mailing list