Odd Freeze on PE4400

Sean McAvoy sean.mcavoy at megawheels.com
Thu Apr 25 13:45:00 CDT 2002


Thanks for the reply, 
I've booted the system into a kernel without bigmem support and the
compile job seems to run fine. problem is, I've got a lot of ram that's
not being used then. I used telnet to connect to port 80 and got a
connect, then tried GET / , no response. Same with SSH, I get a connect
but nothing else. That's why I thought it might be a process limit. I
tried doubling the file-max (to 16384). It seems to have gone a lot
further, then died. 

On Thu, 2002-04-25 at 14:00, Chris Chabot wrote:
> Most of the time when a machine is in a state where it does ping, but does not 
> allow logins, a few plausible reasons exist:
> 
> 1) You ran out of file handles. Since ping is in kernel space it does not need 
> file handles, but loggin in needs about 8+. (this is a limit thats settable 
> via /proc)
> 
> 2) You ran out of memory, as above, and the OOM handler is going bogus.
> 
> 3) Your PAM has gotton very confused, and does not authenticate anything 
> anymore. 
> 
> 4) Your machine's interupts are in a locked stated (this consitutes to a hard 
> crash)
> 
> If you can still open web pages from that server, but not log in, then its 
> likely to be #3.
> 
> If you can not get any reaction from the server that requires file handles 
> (smb, nfs, ssh, telnet, apache, etc), then its likely to be #1
> 
> else it could be #2, or just bad memory, bad kernel in combination with 
> hardware, etc.. In this case i would sugest using a memory test util 
> (freshmeat.net), or using a different kernel (plain 2.4.18 works very well for 
> me).
> 
> Since your machine does ping, #4 is not realy the case. (network card requires 
> interrupt + +kernel + pci bus activity, so those are arguably still 'sane')
> 
> 	-- Chris
> 
> On 25 Apr 2002, Sean McAvoy wrote:
> 
> > Hello,
> > I'm running kernel 2.4.18 with bigmem and SMP enabled (2x1ghz and 2gb
> > RAM), on Debian 3.0. The system freezes when I compile kernels (after
> > getting through much of it), the system is pingable, and you can switch
> > virtual consoles, but you cannot login via console/ssh/telnet. You do
> > get connects when connecting to telnet/ssh/web but that's it.I am
> > wondering if it's a process limit problem, but I've got no sure fire way
> > to tell. Any suggestions?
> > 
> > 
> > 
-- 
Sean McAvoy
Network Analyst
Megawheels Technologies Inc.
Phone: 416.360.8211
Fax:   416.360.1403
Cell:  416.616.6599




More information about the Linux-PowerEdge mailing list