can't compile on 2.4.9-21enterprise

Arjan van de Ven arjanv at redhat.com
Tue Apr 23 02:30:00 CDT 2002


> Install the kernel headers appropriate to your version of kernel and then
> rebuild.  i would make clean ; make dep ; make   from scratch.

Two things:

1) It looked like the orignal mail was about compiling userspace
programs; 
   for that  you need glibc-devel installed

2) you shouldn't take the kernel-headers that match the kernel, you
should
   use the kernel-headers package with which glibc is compiled.
   (Yes I know, the package has a confusing name, hence it's being
renamed
    to glibc-kernheaders in the upcomming release for which skipjack is
the beta)




More information about the Linux-PowerEdge mailing list