PE1650 crashes with 2.4.17

Matt_Domsch@Dell.com Matt_Domsch at Dell.com
Thu Apr 11 14:52:01 CDT 2002


> i have a problem with a pe1650 crashing when the kernel makes the irq
> assignments on boot.

2.4.17 (stock from kernel.org?)
There was a bug in linux/drivers/scsi/aacraid/rx.c where the arguments to
time_before() were reversed which can cause this kind of thing (not a crash
so much as a perceived hang).  It should be time_before(jiffies,start+30*HZ)
rather than (start+30*HZ,jiffies).  This has since been fixed in the 2.4.18
and above kernels.  You can make the simple change yourself to that kernel
if you need 2.4.17 specifically.

Thanks,
Matt

--
Matt Domsch
Sr. Software Engineer
Dell Linux Solutions www.dell.com/linux
Linux on Dell mailing lists @ http://lists.us.dell.com
#1 US Linux Server provider for 2001!




More information about the Linux-PowerEdge mailing list