Broadcom 5700 on Red Hat 2.2.16-22

David Kinnvall david.kinnvall at alertir.com
Wed Oct 31 13:38:01 CST 2001


Just FYI, I am using both Broadcoms (in our 2550's) and
HP Procurve 2524 with the Broadcoms autonegotiating and
functioning perfectly with 100Mbit speeds, full duplex,
and excellent throughput, with no problems whatsoever.
The Procurve is actually a very nice piece of equipment,
at least here. Maybe the problem is caused by a less
than optimal configuration of either component or maybe
it's a driver issue? I am using Red Hat 7.1 with the
2.4.3-12smp kernel and all other relevant errata applied.

As for heavy traffic, I have tested the NIC and switch
combination by simultaneously transferring multiple
.iso-files in both directions, while hammering both
endpoint servers with ApacheBench and running the VA
Cerberus torture-test. (Yeah, I *do* make sure that
our machines are up to the task before I put them into
production. Cruel, perhaps, but comforting. :-) )

Network bandwidth was excellent at all times, with
constant (more or less) speeds at just above 11MB
per second (yes, megabytes), both ways. To make the
setup more interesting I have teamed the Broadcoms
up with the built-in Intel Server adapters using
the Intel e100 and iANS drivers for the NIC's and
automatic fail-over capability, all while randomly
disconnecting patch cables and watching the whole
setup fail-over nicely. No hickups at all, neither
in the Intel NIC's, the Broadcoms nor the Procurve.

(Intel drivers are e100 v1.6.22 and iANS v1.4.27,
 Broadcom driver is v1.4.5 (01/31/01))

For what it's worth.

Regards,

David.

----- Original Message -----
From: "Chris Szilagyi" <chris at groupinfo.com>
To: <JACOB_LIBERMAN at dell.com>
Cc: <linux-poweredge at dell.com>
Sent: Wednesday, October 31, 2001 8:54 PM
Subject: Re: Broadcom 5700 on Red Hat 2.2.16-22


> The switch that the NIC is linked to is a HP Procurve 2524 (J4813A) 10/100
> switch.  Unfortunately this switch is provided by our ISP.  I did notice
that
> the Broadcom NIC was linking at 1/2 duplex, and I tried to force it to 100
Mbps
> full duplex with those params in /etc/modules.conf , but it still linked
at
> half.  The Intel Pro 1000/T in its place links up at half duplex
automatically
> as well, but doesn't have any problems with it.  Were you guys thinking
that
> since the Broadcom NIC was only linked at half duplex, that this is
causing a Tx
> bottleneck for the adapter???  Our ISP is eventually going to replace the
10/100
> switch with a gigabit switch or a gigabit media converter, so I guess we
could
> see if the problem persists after that.  Thanks for all of your help and
if you
> think of anything else please drop me a note.
>
> --
> Chris
>
> JACOB_LIBERMAN at Dell.com wrote:
>
> > Chris,
> >
> > We haven't seen any problems with the broadcom module. What is the
> > make/model of the switch you're using?
> >
> > Based on the error log, it looks like the NIC is having trouble
> > autonegotiating with the switch. (Unless you're running it at 100mbs 1/2
> > duplex intentionally.)
> >
> > If you want to hard set the NIC to 100Mbs & 1/2 duplex, add
> >
> > line_speed=100 full_duplex=0
> >
> > next to the alias for the NIC in /etc/modules.conf
> >
> > If you're trying to run the NIC at 1000 Mbps, leave the line_speed
parameter
> > alone. Default =0 (autonegotiate.) Default full_duplex=1 (full duplex.)
> >
> > The bcm module also accepts rx_flow_control, tw_flow_control, and
> > auto_flow_control parameters.
> >
> > Jacob
> >
> > -----Original Message-----
> > From: Chris Szilagyi [mailto:chris at groupinfo.com]
> > Sent: Tuesday, October 30, 2001 7:38 AM
> > To: linux-poweredge at exchange.dell.com
> > Subject: Broadcom 5700 on Red Hat 2.2.16-22
> >
> > Hello,
> >
> > We recently purchased a PowerEdge 2550 (with the integrated Broadcom
5700
> > gigabit adapter) and the Intel Pro 1000/T server adapter.  The server is
> > acting as a firewall using the two gigabit adapters.  During
> > very heavy traffic through the machine, the Broadcom adapter will drop
> > offline briefly, then come back up.  Right when this happens, looking in
> > /var/log/messages shows us the following:
> >
> > Oct 26 13:05:15 fw kernel: eth0: Tx hung
> > Oct 26 13:09:24 fw kernel: eth0: Link up, 100 Mbps half duplex
> >
> > We have tried the Broadcom driver v 1.4.5, supplied by Dell, and also
the
> > Broadcom driver v 1.4.6 supplied by 3com for the 3c996, which we have
found
> > has the Broadcom chip in it.  We tried both of these drivers with the
> > 2.2.16-22 kernel, and with the 2.2.19-7.0.10enterprise kernel, and get
the
> > same results.  We also tried the obvious by using different ethernet
cables
> > and plugging into a 10/100 switch and a gigabit switch. Still, the same
> > problem.
> >
> > I was wondering if anybody else has seen the Broadcom adapter do this. I
> > would also appreciate any feedback on how stable this adapter is and how
> > stable the driver for Linux is.  We are temporarily using two Intel Pro
> > 1000/T adapters and they are rock solid.
> >
> > Thanks in advance,
> > --
> > Chris
> > Group InfoTech, Inc.
>
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com
> http://lists.us.dell.com/mailman/listinfo/linux-poweredge
>




More information about the Linux-PowerEdge mailing list