Broadcom 5700 on Red Hat 2.2.16-22

Chris Szilagyi chris at groupinfo.com
Tue Nov 20 13:35:00 CST 2001


I have compiled and installed these drivers, under the 2.2.19-7.0.10enterprise
kernel released from Red Hat.  The problem we were having before is definitely
gone now, as I have done some extensive load testing and everything is up to
speed, with no drops or hangups.  Thanks to Ard van Breemen for sending those
drivers along...

--
Chris

Ard van Breemen wrote:

> On Tue, Oct 30, 2001 at 08:37:31AM -0500, Chris Szilagyi wrote:
> > Oct 26 13:05:15 fw kernel: eth0: Tx hung
> > Oct 26 13:09:24 fw kernel: eth0: Link up, 100 Mbps half duplex
>
> > We have tried the Broadcom driver v 1.4.5, supplied by Dell, and also the
> > Broadcom driver v 1.4.6 supplied by 3com for the 3c996, which we have found
> > has the Broadcom chip in it.  We tried both of these drivers with the
> > 2.2.16-22 kernel, and with the 2.2.19-7.0.10enterprise kernel, and get the
> > same results.  We also tried the obvious by using different ethernet cables
> > and plugging into a 10/100 switch and a gigabit switch. Still, the same
> > problem.
> You can try the "latest" broadcom drivers.
> You can download them from:
> http://ftp.debian.org/debian/pool/main/b/bcm5700/bcm5700_2.0.24.orig.tar.gz
> I will upload version 2.0.27 soon now...
> One note however: You cannot ask support for this driver from broadcom.
> If you find a bug, you should file it as a debian user according to
> debian standards.
> If you just use
> > I was wondering if anybody else has seen the Broadcom adapter do this. I
> > would also appreciate any feedback on how stable this adapter is and how
> > stable the driver for Linux is.  We are temporarily using two Intel Pro
> > 1000/T adapters and they are rock solid.
> I use the 2.0.24 driver in a test setup at 100Mbit Full duplex...
> It seems rather stable. I have attacked it with about 70000 packets
> per second. It did not barf on me once.
>
> I have seen the same problems with the intel e100 drivers. The 1.6.6
> drivers went as far as to just stop... The 1.6.22 drivers seem to reset
> the chip somehow, and then continue. I attack these with 132000 packets
> per second, and they barfed once due to downing and upping the interface.
>
> I guess your biggest problem is running half duplex. I've seen lockups
> before, not even the intel ether expres, but also the i82596.
> That one locked up frequently, and then I had to reset all irq circuitry
> etc...
>
> However, you might find this interesting (from the changelog)
> v1.5.4 (05/04/01)
>
> - Fixed interrupt and TX hung problem on 5701.
> - Added OEM strings.
>
> Find attached the release notes for 2.0.24
> --
> <ard at telegraafnet.nl> Telegraaf Elektronische Media  http://wwwijzer.nl
> http://leerquoten.monster.org/ http://www.faqs.org/rfcs/rfc1855.html
> Let your government know you value your freedom. Sign the petition:
> http://petition.eurolinux.org/
>
>   ------------------------------------------------------------------------
>
>    RELEASE.TXTName: RELEASE.TXT
>               Type: Plain Text (text/plain)




More information about the Linux-PowerEdge mailing list