Can't see DLT drive on PE2500?

Chris Chabot chabotc at reviewboard.com
Tue Nov 13 13:24:00 CST 2001


Hi Carl,
the tape drive, if correctly detected, should be registered to /dev/st0.

(note: not to have to give the -f param the whole time, you can do a ln
-s /dev/st0 /dev/tape This is the 'default' device for mt).

the things you want to watch for:
first, is the tape drive listed in the kernel's scsi detection? Should
give u a line like:
	Vendor: Seagate Model: DAT Rev: ... etc
if this is true, you know the scsi part of the deal is working. If that
is _not_ the case, it is not connected properly.

next, check to see if you see a line like the folowing in the boot
messages:
	Attached scsi tape stX at scsiX, Channel X, id X

if this is _not_ the case, but the tape drive is listed in the scsi
detection, this means the scsi-tape driver is not loaded. Check to see
which modules you need to load for the tape drive, modprobe those, and
see if then /dev/st0 works..

if that fails, compile ur own kernel with scsi + scsi hd + scsi tape
hard-compiled in..

	-- Chris




On Tue, 2001-11-13 at 18:19, Carl Gibbons wrote:
> 
> Hi!  My team purchased a new Poweredge, which we're hoping to use (among
> other tasks) as a backup server.  It came with a DLT tape drive.  Dell
> preinstalled RedHat 7.1; after booting and configuring the machine, we
> rebooted with RedHat 7.2 CDs and chose the "Upgrade existing installation"
> option, so now I have RedHat's 2.4.7-10smp kernel.
> 
> According to page 1-4 of
> 
>    http://docs.us.dell.com/docs/software/lnx7132/lnx7132.pdf
> 
> I should be able to "mt -f /dev/st0 status" and such.  Instead, I get
> "/dev/st0: no such device."  Since we have six disks on three SCSI
> controllers and a PERC controller RAIDing them all, I thought perhaps the
> DLT was connected to some other controller, so I tried all of the /dev/st1
> through /dev/st31 entries; none of them worked either.  How do I use the
> DLT drive?
> 
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com
> http://lists.us.dell.com/mailman/listinfo/linux-poweredge





More information about the Linux-PowerEdge mailing list