Perc3/Di on PE2550 with Suse Linux Email Server II (Runs on 2 .2.16 kernel)

Matt_Domsch@Dell.com Matt_Domsch at Dell.com
Sat Nov 10 07:33:00 CST 2001


> I am having problems getting the correct per driver 
> (aacraid.o) for the 
> 2.2.16 kernel. I am trying to install Suse Email server II on 
> a PowerEdge 
> 2550 with a Perc3/DI ROMB. 

In that time frame, SuSE wasn't including the aacraid driver in their kernel
(no one was).

> am I going to have to bring up 
> another system and compile it myself?

Basically, yes.  The driver source is on http://domsch.com/linux/#aacraid,
though you may want to try to make the later patch apply to the 2.2.16
kernel.  We haven't done development/backport of fixes from recent 2.4.x to
2.2.x though, so at least you'll need to patch aacid.c to have the latest
list of PCI ids for the 2550.  For a fee, I'm sure SuSE can assist.  Or,
consider running Red Hat Linux 7.1 or 7.2, which handles this device
automatically.

Thanks,
Matt

-- 
Matt Domsch
Sr. Software Engineer
Dell Linux Solutions
www.dell.com/linux
#2 Linux Server provider with 17% in the US and 14% Worldwide (IDC)!
#3 Unix provider with 18% in the US (Dataquest)!



More information about the Linux-PowerEdge mailing list