Kernel panics with 7.2 and ANS

Jeremy Stoltz jstoltz at oz.net
Mon Nov 5 19:18:01 CST 2001


I ended up upgrading the kernel to 2.4.9-13 and using the default e100
drivers with no Etherchannel. I brought one of the boxes back to the office
to do some testing on. I'll send a copy to this list and Intel once I get a
chance. Are there any other options then iANS to use etherchannel or at
least load balancing between two nics?

Jeremy


----- Original Message -----
From: "David Kinnvall" <david.kinnvall at alertir.com>
To: <Linux-PowerEdge at dell.com>
Sent: Monday, November 05, 2001 12:01 PM
Subject: Re: Kernel panics with 7.2 and ANS


> From: "Ard van Breemen" <ard at telegraafnet.nl>
> > On Mon, Nov 05, 2001 at 10:45:59AM -0800, Jeremy Stoltz wrote:
> > > I have several 1550's which I recently started using Intel's ANS
drivers
> and
> > > etherchannel. I was having problems with occasional kernel panics on
the
> > > machines. Yesterday I upgraded the machines to use e100-1.6.22 and
> > > iANS-1.4.27. I saw a kernel panic on most of the machines with in a
few
> > > hours of the upgrade.
> > >
> > > I'm using Redhat 7.2 with 2.4.7-10smp on these machines. Any
suggestions
> on
> > > how to
> > > resolve this issue?
> > Yes: use a serial console, and cut and paste the panics and the oopses,
> > and send them to this list.
> > Ehhh, also run them through ksymoops before sending them to this list.
> > If the panic seemed to be caused by iANS, you have to contact intel.
> > Anyway, by using iANS, your kernel is tainted, so support is less
> > likely to come from kernel-hackers.
> > But without the panics and the oopses, we cannot help you.
>
> To add one more, albeit neither this one with anything more
> helpful such as panics and/or oopses, I ran into this one as
> well. Crashes with iANS loaded, on any kernel except the
> 2.4.3 from Red Hat 7.1. Upgrades to later kernels for 7.1
> or a major upgrade to Red Hat 7.2 with any of the kernels
> available for that release all lead to the same result:
> crash and burn. Remove the iANS driver and all is well.
>
> Temporary solution on my part: Run Red Hat 7.2 on my dev.
> servers in-house without iANS, stay with Red Hat 7.1 and
> 2.4.3 on my production servers and wait. If I get the time
> and hardware necessary I'll try to reproduce and record
> some useful data next time around.
>
> In other words: It's a problem with iANS and kernel revs.
>
> This would be the time to bug Intel, I guess.
>
> Regards,
>
> David.
>
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com
> http://lists.us.dell.com/mailman/listinfo/linux-poweredge
>




More information about the Linux-PowerEdge mailing list