Drive blowing up backplane in 2450 and 2400

Hubbard, David dhubbard at dino.hostasaurus.com
Tue Jun 19 11:50:00 CDT 2001


Hi all,
	I guess this problem isn't specifically linux
related but my servers are running linux. :-)  This is
a long story, but please read it and help me... LOL

Basically, this is a very very weird problem.  I have
a Dell 2400 and 2450.  The 2400 came with a 9 gig
Quantum drive and has the raid card enabled.  I bought
two identical quantum's from CDW and threw them in
there.  This setup has worked for a year.  I now need
more space and I just happened to have two Sun-branded
18 GB Seagate Cheetah ST318404LC SCA drives sitting
around.  I bought a third regular Seagate ST381404LC
from CDW to make a set of three for RAID5 in my three
remaining 2400 bays.  The differences are that the
Seagate sticker includes a Sun part number, the
firmware says ST381404SUN when you look at it and it
has half as many cylinders as the PC version, nothing
major there.

Well, two weekends ago I go to throw these three drives
in and only the two Sun-branded drives show up in the
RAID bios.  I immediately thought "Ok, a dead drive no
big deal", shut down, and pulled it out.  I moved the
two sun drives down to take the spot where this one had
been and turned back on.  Now I couldn't see the drive
that had been moved into the slot the bad drive was in.
I then figured, wow, this bad drive has an electrical
problem and blew the slot out on the backplane.  On
Monday morning I got Dell to ship me a new backplane
and Seagate to ship me a new drive.  This past weekend
I swapped the backplane and then put the two Sun drives
and the replacement Seagate drive back in.  THE SAME
THING HAPPENED!!  I couldn't believe it.  I moved the
replacement drive around and it apparently burned out
each slot I tried it in on this new backplane.

Now, just for curiosity, I threw all three drives in a
Sun Enterprise 450 server I have sitting here next to
the Dell and they worked perfectly!!  I then tried them
in a Sun A1000 disk array, they worked perfectly again.
I even tried the original Seagate drive that I had got
the replacement for and it worked perfectly.  Since the
only real difference in the drives is the number of
cylinders they report, and the RAID controller in the
Dell should worry about that, I don't see what the
problem could be.  In a final spurt of curiosity, I
tossed the drives in a spare Dell 2450 and in this one,
I actually smelled a burning smell a few seconds after
I turned it on.  I immediately turned it off and put
it's normal drives back in, what do you know, the
stock Seagate drives blew out the slots I had put them
in!

So my question is, what is weird about the stock Seagate
18G Cheetah drive that can cause it to physically burn
out a SCSI backplane slot in a 2400 and 2450 server
while the Sun versions of the drive, whose only
difference is the firmware, do not cause the problem, and
all continue to work in a Sun even after burning out
the Dell slots?  Does anyone have a 2400 with 18 GB
10,000 RPM drives in it that work that they bought
themselves?  Can you tell me which models, I'd like to
get some. :-)

I talked to Seagate and they say the problem is Dell's
since their drives, in Sun form and stock PC form,
both worked in the Sun servers.  They did say that the
newer ST318405LC drive does have a known problem similar
to this with some servers but the 404LC should not
have any problems with anything.  I'm going to call
Dell but I wanted to see what people here think first.

Thanks,

Dave



More information about the Linux-PowerEdge mailing list