Trying to build Intel ANS... failing!

Michael E Brown michael_e_brown at dell.com
Wed Aug 15 08:33:01 CDT 2001


The Intel ians driver builds against the kernel sources contained in
/usr/src/linux. These do not match your running kernel, as the message
indicates. To get them to match your running kernel, do the following:

cd /usr/src/linux
make mrproper
cp configs/kernel-*-i686-enterprise.config ./.config
make dep
make bzImage modules

Then you should be able to build your ians driver properly.
--
Michael Brown
Linux OS Development
Dell Computer Corp


On Wed, 15 Aug 2001, Basil Hussain wrote:

> Hi,
>
> I'm hoping someone can help me with a problem I'm having trying to install
> Intel's Advanced Networking Services on a dual-cpu Poweredge 1550 running
> RedHat 7.0 (factory-installed).
>
> As far as I can tell, I have the current version of the e100 Intel network
> card drivers (1.2.1) and the current version of ANS (1.3.34).
>
> The problem occurs when I try to load the ians.o module using 'insmod'. I
> just get a bunch of errors about unresolved symbols. I take this to mean
> that it hasn't been built properly in the first place.
>
> Initially, I did have some trouble getting it to build, as the make process
> complained that the kernel sources didn't match the kernel actually running
> (it's running 2.2.16-22enterprise), but this seemed to be because it was
> trying to use the UP sources, rather than SMP sources:
>
> Makefile:127: ***
> Makefile:132: *** Warning: kernel source configuration (UP)
> Makefile:133: *** does not match running kernel (SMP)
> Makefile:135: *** Continuing with build,
> Makefile:136: *** resulting driver may not be what you want
> Makefile:137: ***
>
> (The output above is simply the first few lines - lots of other errors
> follow. I can post the complete error log from the make process if anyone
> wants.)
>
> But, there were a couple of options you could give the make process:
>
> SMP=[0/1]         compile with smp disabled/enabled
> MODVERSIONS=[0/1] compile with modeversions disabled/enabled
>  (Default values are taken from the kernel headers)
>
> So, I tried again (after a 'make clean') with the option of SMP=1. The build
> yields no errors this time, apart from this single warning:
>
> {standard input}: Assembler messages:
> {standard input}:9: Warning: Ignoring changed section attributes for
> .modinfo
>
> I have no idea what this means. And, the module still doesn't work with the
> same bunch of errors about unreolved symbols.
>
> Does anyone have any ideas what's wrong? Has anyone actually got Intel ANS
> working with their Dell server under Linux?
>
> Regards,
>
> Basil Hussain
> ---------------------------------------
> Internet Developer, Kodak Weddings
> E-Mail: basil.hussain at kodakweddings.com
>
> P.S. I haven't tried the scripted installation routine yet. If it actually
> works, please let me know, as I'm a bit loath to experiment with it, as it
> could be doing anything...
>
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com
> http://lists.us.dell.com/mailman/listinfo/linux-poweredge
>

-- 
--
Michael Brown
Linux OS Development
Dell Computer Corp

  If each of us have one object, and we exchange them,
     then each of us still has one object.
  If each of us have one idea,   and we exchange them,
     then each of us now has two ideas.





More information about the Linux-PowerEdge mailing list