Ubuntu on Vostro 3560

Bartek eebee at go2.pl
Wed Aug 15 10:15:52 CDT 2012


Hi,
I've got a new Vostro 3560 more less like that one http://www.ubuntu.com/certification/hardware/201202-10402/ but with i5-3210m and bd-rom.

It came to me with factory installed Ubuntu 11.10 and from the very beginning wasn't working the way (I think) it was supposed to:
1 finger print reader not working,
2 short battery runs on low performance tasks (about 2h),
3 no switching between graphic cards,
4 no Intel Turbo Boost (only 1,2 - 2,5 GHz),
5 lots of problems with connecting to most of wireless networks,
6 dell buttons above keyboard not associated with any functions,
7 some freezes etc.

I tried to update all packages, then upgrade do 12.04. Wifi seems to work better, but still not always connects / works stable with some routers.
http://ubuntuforums.org/showthread.php?t=1930450 & http://ubuntuforums.org/showpost.php?p=12098495&postcount=356 improved problems #2 (still < 3h runs) and #3.

I tried newer kernels from http://kernel.ubuntu.com/~kernel-ppa/mainline/ (3.4, 3.5, 3.5.1) in hope for better support for notebook's new parts, but had troubles with dell-laptop-oneric (3.5, 3.5.1) and wireless-iwlwifi-oneiric (all mentioned before) while installing linux-headers. Uninstalling wireless-iwlwifi-oneiric before installing 3.4 kernel let the installation finish, but anyway I had troubles after booting with new kernel - crashes, no wifi or no touchpad and mouse.

What should I install after installing new kernel to make it work like a charm?
Maybe I should post here hwinfo output or some error logs?

Regards,
Bartek



More information about the Linux-Desktops mailing list