Broadcom Wireless problems - Solved!

Nigel Ridley nigel at prayingforisrael.net
Sat Mar 28 13:03:35 CDT 2009


Nigel Ridley wrote:
> Mario Limonciello wrote:
>> Don't trust what it say on the live disk about "enabled but not in
>> use".  Actually try it out.  There is a bug in Intrepid and a lot of
>> Jaunty that it can show that when really the driver is in use and
>> functional.  It's been fixed in Jaunty post A6 updates however (version
>> ***0.5-0ubuntu2
>> <https://edge.launchpad.net/ubuntu/+source/jockey/0.5-0ubuntu2>* and later).
> 
> Thanks Mario,
> 
> However it doesn't work on the Vostro BUT does on the Inspiron! The exact same card and the exact 
> same Live CD but different results between the Vostro and the Inspiron.
> 
> If I have time over the weekend I am going to try to do a fresh install of Jaunty from the 'Daily 
> Build':
> http://cdimage.ubuntulinux.org/non-ports/kubuntu/daily/current/
> 
> See what happens....
> 
> Blessings,
> 
> Nigel
> 
>> Nigel Ridley wrote:
>>> I am trying to get a Broadcom Corporation BCM4312 802.11b/g (rev 01) wireless card working on a 
>>> Vostro A860 running Kubuntu Hardy (8.04).
>>> I have the same card in my Inspiron 1525 which works OK.
>>>
>>> I did try experimenting with the latest Kubuntu Live CD (Jaunty Alpha 6) and on my Inspiron it 
>>> works just fine (I just need to click on the taskbar network icon and choose my linksys router).
>>> On the Vostro, using the Kubuntu Live CD (Jaunty Alpha 6) the taskbar network icon shows that the 
>>> wireless is disconnected and when I try the Hardware Driver Manager it shows the 'wl' driver as 
>>> enabled but 'Not in Use'.
>>>
>>> What is the difference (hardware wise) between the Vostro and the Inspiron that, both using the 
>>> exact same wireless cards (I even swapped the cards from one laptop to the other, just to make 
>>> sure) one works and the other doesn't?
>>>
>>> Blessings,
>>>
>>> Nigel

Replying to myself here:

With the recent Hardy updates I can now see the 'wl' module and a quick 'sudo modprobe wl' loads 
the module but I couldn't access the wireless :-(
When I tried:

sudo iwlist eth1 scan

I got:
eth1 Failed to read scan date : Invalid argument

A quick Google gave me a clue - 'Fn F11' duh! I had the wireless switched off!!

Now everything is working fine.
I even added a new line to 'etc/modules' with 'wl' on it (without the quotes) so that the wl 
module loads at boot.

So the morale of the story is "Did you check that the wireless is switched on?"

Blessings,

Nigel



More information about the Linux-Desktops mailing list