HDMI audio on 1525, silent

Tom Chiverton tom.chiverton at gmail.com
Mon Mar 16 13:51:34 CDT 2009


2009/3/16  <Mario_Limonciello at dell.com>:
>device in mplayer should work.

As in the '-ao' option below ? Still silence. Leaving off the -ao I
get sound from the laptop speakers fine.
I logged into Gnome, and even the 'test' button in
gnome-sound-properties doesn't make a noise when the 'ATI HDMI' drop
down is selected for instance.
Toggling 'IEC958' in 'gnome-alsa-mixer' brings no change either.

The socket and 'file or directory' pair of errors below appear to be
from remote control support, and occur even without the -ao option.

$ mplayer -ao alsa:device=hw=0.3 /home/falken/Desktop/star\
fleet/Star\ Fleet\ Volume\2.avi
MPlayer 1.0rc2-4.3.2 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU     T5550  @ 1.83GHz (Family: 6,
Model: 15, Stepping: 13)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /home/falken/Desktop/star fleet/Star Fleet Volume 2.avi.
AVI file format detected.
[aviheader] Video stream found, -vid 0
[aviheader] Audio stream found, -aid 1
VIDEO:  [DX50]  352x288  24bpp  25.000 fps  500.0 kbps (61.0 kbyte/s)
xscreensaver_disable: Could not find XScreenSaver window.
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Forced audio codec: mad
Opening audio decoder: [libmad] libmad mpeg audio decoder
AUDIO: 11025 Hz, 2 ch, s16le, 24.0 kbit/6.80% (ratio: 3000->44100)
Selected audio codec: [mad] afm: libmad (libMAD MPEG layer 1-2-3)
==========================================================================
AO: [alsa] 32000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 352 x 288 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.22:1 - prescaling to correct movie aspect.
VO: [xv] 352x288 => 352x288 Planar YV12
A:   2.1 V:   2.1 A-V: -0.000 ct:  0.007  54/ 54 16%  0%  1.0% 4 0


-- 
Tom



More information about the Linux-Desktops mailing list