sound problem

oldcpu oldcpu at opensuse-forums.org
Fri Mar 6 13:07:43 CST 2009


Installing the latest alsa-drive-kmp-pae rpm from the openSUSE 'git'
repository for alsa, fixed the problems. The speakers are now properly
automuted when the headset is plugged in.

The openSUSE/alsa dev was very very fast in fixing this. Details in the
bug report: https://bugzilla.novell.com/show_bug.cgi?id=482052

Once again a happy camper. :)


oldcpu wrote:
> I found the latest 2.6.27.19_3.2.1 kernel on openSUSE-11.1, even with
> the latest 1.0.19 git alsa packaged rpms installed, has broken the auto
> mute for the speakers, when the headphones are pluged in my Dell Studio
> 15 (1537) laptop.
>
> So I wrote this bug report:
> https://bugzilla.novell.com/show_bug.cgi?id=482052
>
> If this is not fixed in a couple of weeks (before my next vacation) I
> may roll back to the older kernel.
>
> Mayank Daga wrote:
>   
>> On Sun, Mar 1, 2009 at 6:52 PM, oldcpu <oldcpu at opensuse-forums.org
>> <mailto:oldcpu at opensuse-forums.org>> wrote:
>>
>>     There was a kernel update earlier this week on openSUSE-11.1 to the
>>     2.6.27.19_3.2.1 kernel, and that broke the sound on some new Dell
>>     computers running openSUSE-11.1 Linux.  For example it very briefly
>>     broke the sound on my Dell Studio 15 running openSUSE-11.1.
>>
>>     But the fix is easy, if your Dell has internet access.  There is
>>     guidance here:
>>     http://en.opensuse.org/Alsa-update
>>
>>     You must send six zypper commands. Three commands to update the basic
>>     alsa packages (such as alsa, alsa-oss, alsa-plugins,
>>     alsa-plugins-pulse,
>>     alsa-utils, ... etc ... ).  And three commands to install the
>>     basic alsa
>>     driver (alsa-driver-kmp-your-kernel-verison).
>>
>>     You can tell what alsa rpms you have installed by typing:
>>         rpm -qa | grep alsa
>>
>>     You can tell what kernel you have installed by typing:
>>         uname -a
>>
>>     In my case, since I had the 2.7.27_9.1-6.1-pae kernel (which was
>>     updated
>>     to the 2.6.27.19_3.2.1-pae kernel), and I had in place older
>>     versions of
>>     alsa, alsa-utils, alsa-plugins, alsa-plugins-pulse, alsa-firmware,
>>     alsa-tools, alsa-oss) I simply sent the following 6 zypper comamnds
>>     (note your commands may be different based upon your kernel
>>     version (ie
>>     default or pae)). I also typed 'su' first (no quotes - enter root
>>     password) to get root permissions:
>>
>>             zypper ar
>>     http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.1/
>>     multimedia
>>
>>             zypper install alsa alsa-oss alsa-plugins
>>     alsa-plugins-pulse alsa-utils alsa-tools alsa-firmware libasound2
>>
>>             zypper rr multimedia
>>
>>             zypper ar
>>     http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1_Update/
>>     multimedia
>>
>>             zypper install alsa-driver-kmp-pae
>>
>>             zypper rr multimedia
>>
>>
>>
>> I performed all these commands and then restarted and found that the
>> sound was working.
>>
>> But after restarting, as soon as I went to YaST, there was a problem
>> again and the sound is not working anymore. I re did these commands
>> but they say "nothing to do". The sound is not working anymore. I am
>> GNOME, if it matters anyways.
>>
>> Please help.
>>
>>
>>
>>
>>     And then I restarted my PC, went to YaST > Hardware > Sound > Other >
>>     Volume and moved both PCM and Master volume to around 95%, and then
>>     closed YaST. Then I went to my mixer (kmix on my KDE-3.5.10) and moved
>>     up PCM and Master to a reasonable setting, and I had sound.
>>
>>     Thats all.
>>
>>     Good luck.
>>
>>     Lee (aka oldcpu)
>>
>>
>>     Mayank Daga wrote:
>>     > suddenly sound not working on suse11.1 on inspiron 1420.
>>     >
>>     > please help.
>>     >
>>     > --
>>     > Regards,
>>     > Mayank Daga
>>     > Senior Undergraduate Student,
>>     > Department of Information Technology,
>>     > National Institute of Technology, Durgapur,
>>     > India
>>     >
>>     ------------------------------------------------------------------------
>>     >
>>     > _______________________________________________
>>     > Linux-Desktops mailing list
>>     > Linux-Desktops at dell.com <mailto:Linux-Desktops at dell.com>
>>     > http://lists.us.dell.com/mailman/listinfo/linux-desktops
>>     > Please read the FAQ at http://lists.us.dell.com/faq
>>
>>     _______________________________________________
>>     Linux-Desktops mailing list
>>     Linux-Desktops at dell.com <mailto:Linux-Desktops at dell.com>
>>     http://lists.us.dell.com/mailman/listinfo/linux-desktops
>>     Please read the FAQ at http://lists.us.dell.com/faq
>>
>>
>>
>>
>> -- 
>> Regards,
>> Mayank Daga
>> Senior Undergraduate Student,
>> Department of Information Technology,
>> National Institute of Technology, Durgapur,
>> India
>>     
>
> _______________________________________________
> Linux-Desktops mailing list
> Linux-Desktops at dell.com
> http://lists.us.dell.com/mailman/listinfo/linux-desktops
> Please read the FAQ at http://lists.us.dell.com/faq
>
>   



More information about the Linux-Desktops mailing list