Ability to run X-plane Broken when upgrading to 8.10 (Ian)

Tom & Karen Pino metalsmith at rangeweb.net
Wed Dec 3 23:37:57 CST 2008


I have no idea if you have solved this problem. I run Hardy. Synaptic 
lists libopenal0a for me. This was found by a search for libopenal.

I would suggest running that search in Intrepid Synaptic and then 
installing through terminal what you find. the reason for that is that 
terminal will give you a list of recommended packages and suggested 
packages. What you need may be one of those in addition to what you have.

Synaptic shows this as installed on my box. Even if it is listed this 
way on yours, an apt-get install should show that it is the latest 
version but still show the other related packages.
Tom

Mircea Vutcovici wrote:
> To find all libraries the program might need:
> ldd X-Plane-i686
> Then try to find a similar one probably in /usr/lib and create a
> symlink with the name required by your program to the shared library:
> ldconfig -p | grep libopenal
> If you can not find it, try to install the library with
> apt-get/aptitude/synaptic. I think you will need to install libopenal1
>
> On Sat, Nov 29, 2008 at 11:07 AM, Ian <ixb at videotron.ca> wrote:
>   
>> All,
>> When I try to run in a terminal using ./ I get
>>
>> ian at dell-desktop:~/X-Plane 9$ ./X-Plane-i686
>> ./X-Plane-i686: error while loading shared libraries:
>> libopenal.so.0:
>> cannot open shared object file: No such file or directory
>>
>> Trying to execute the load/reload macro from the DVD
>> doesn't work either.  I have been unable to find this OpenAL library
>> compiled for Ubuntu (if that's what the libopenal.so.0 means), and I'm
>> reluctant, as a novice user, to try doing it myself.
>>
>> Regards,
>> Ian
>>     
>
> _______________________________________________
> Linux-Desktops mailing list
> Linux-Desktops at dell.com
> http://lists.us.dell.com/mailman/listinfo/linux-desktops
> Please read the FAQ at http://lists.us.dell.com/faq
>
>   



More information about the Linux-Desktops mailing list