Sound on D630

Thorsten Leemhuis fedora at leemhuis.info
Mon Jul 2 03:53:57 CDT 2007


On 02.07.2007 10:45, James Jarvis wrote:
> I saw similar kernel messages when inserted the snd-hda-intel kernel module
> so I expect problem will need to be addressed upstream in that kernel
> module. [...]

>From reading the alsa-doc I suspect it's not a problem in the module --
I tend to say the module has problems to access the hardware, so it
might be some hardware-routing issue (but that is pure speculation).

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=blob_plain;f=Documentation/sound/alsa/ALSA-Configuration.txt;h=355ff0a2bb7c5a1cdc9862c4f827e9e49497c165
[...]
Module snd-hda-intel
[...]
    single_cmd  - Use single immediate commands to communicate with
                codecs (for debugging only)
[...]
    NB: If you get many "azx_get_response timeout" messages at
    loading, it's likely a problem of interrupts (e.g. ACPI irq
    routing).  Try to boot with options like "pci=noacpi".  Also, you
    can try "single_cmd=1" module option.  This will switch the
    communication method between HDA controller and codecs to the
    single immediate commands instead of CORB/RIRB.  Basically, the
    single command mode is provided only for BIOS, and you won't get
    unsolicited events, too.  But, at least, this works independently
    from the irq.  Remember this is a last resort, and should be
    avoided as much as possible...
[...]

CU
thl
>> -----Original Message-----
>> From: Thorsten Leemhuis [mailto:fedora at leemhuis.info] 
>> Sent: 01 July 2007 16:28
>> To: James.Jarvis at ed.ac.uk; linux-desktops at dell.com
>> Subject: Re: Sound on D630
>>
>> /me again! Just FYI, in case someone stumbles about my posts 
>> via google
>>
>> On 30.06.2007 18:09, Thorsten Leemhuis wrote:
>>> On 30.06.2007 14:45, Thorsten Leemhuis wrote:
>>>> On 04.06.2007 12:25, James Jarvis wrote:
>>>>> [...] Has anyone managed to get the audio and modem 
>> working on the 
>>>>> High Definition Audio bus on the Dell Latitude D630?
>>>> Same question here (albeit I don't care about the modem); 
>> my new Dell 
>>>> D630 arrived yesterday and I installed Fedora Core 7 on it (¹). No 
>>>> sound; I then tried a 2.6.22-rc6 kernel from rawhide -- 
>> same problem.
>>>> [...]
>>>> I tried several things (pci=nomsi, pci=noapic for the 
>>>> kernel;snd-hda-intel options single_cmd=1, probe_mask=1 and some
>>>> others) -- no luck.
>>>> [...]
>>>> So, did anybody else get the D630 to play audio?
>>> I did get audio to work now with the Ubuntu Feisty kernel 
>>> (vmlinuz-2.6.20-16-generic; installed in Fedora). I'm investigating 
>>> now what they are doing differently (it does not work with a Fedora 
>>> Core 7 kernel based on 2.6.20). But seems Ubuntu has the 
>> same problem 
>>> these days, as audio with kernel vmlinuz-2.6.22-7-generic (the one 
>>> prepared for Gutsy Gibbon afaik) does not work.
>> I built a Fedora 7 kernel 2.6.21-1.3241.fc7 now (¹) and 
>> modified it, so alsa and snd-hda-intel gets compiled in; I 
>> found that hint on 
>> http://mailman.alsa-project.org/pipermail/alsa-devel/2007-June
> /001515.html
>> Now audio is working fine!
>>
>> I also tried to compile alsa-hg, but that did not help for me 
>> (it helped in 
>> http://mailman.alsa-project.org/pipermail/alsa-devel/2007-June
> /001517.html
>> )
>>
>> Nevertheless it's not perfect:
>>
>> hda_intel: azx_get_response timeout, switching to polling mode...
>> hda_intel: azx_get_response timeout, switching to single_cmd mode...
>> ALSA device list:
>>   #0: HDA Intel at 0xfe9fc000 irq 21
>>
>> Likely still something with the hardware routing.
>>
>> Cu
>> thl
>>
>> (¹) -- that one contains a patch to recognize the DVD-reader 
>> as well; yay! Thanks Chuck!
>>
>>
> 



More information about the Linux-Desktops mailing list